Closed Bug 1638981 Opened 11 months ago Closed 6 months ago

Convert 'mach reftest' to run with Python 3

Categories

(Testing :: Reftest, task)

task

Tracking

(firefox78 wontfix, firefox84 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- wontfix
firefox84 --- fixed

People

(Reporter: KrisWright, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

mach reftest still runs with python 2 [1]. We want to convert all mach commands to python 3.

To do this, any dependencies of the command may need to be converted as well as the command itself.

[1] https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/layout/tools/reftest/mach_commands.py

Assignee: nobody → bob
Status: NEW → ASSIGNED
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58c9cabb488a
enable mach reftests to run with Python 3. r=gbrown
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Regressions: 1641742

I am going to revert the change to mach due to multiple issues with android.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

I'm un-assigning myself until the time where we have more of the underlying infrastructure ported to support python3.

Assignee: bob → nobody

Hi -- is there a status update on this work?

Flags: needinfo?(kats)

These work for me now, thanks to your earlier work on reftest and my earlier
work on mochitest.

Assignee: nobody → whole.grains
Attachment #9184081 - Attachment description: Bug 1638981 - Run 'mach reftest' and 'mach crashtest' with python 3; r= → Bug 1638981 - Run 'mach reftest', 'mach crashtest', and 'mach jsreftest' with python 3; r=
Pushed by whole.grains@protonmail.com:
https://hg.mozilla.org/integration/autoland/rev/40e959018c2b
Run 'mach reftest', 'mach crashtest', and 'mach jsreftest' with python 3; r=bc
See Also: → 1638956
Status: REOPENED → RESOLVED
Closed: 11 months ago6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.