Closed Bug 1638991 Opened 11 months ago Closed 20 days ago

Convert 'mach telemetry-tests-client' to run with Python 3

Categories

(Toolkit :: Telemetry, task, P1)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: KrisWright, Assigned: raphael)

References

(Blocks 1 open bug)

Details

Attachments

(4 files, 2 obsolete files)

mach telemetry-tests-client still runs with python 2 [1]. We want to convert all mach commands to python 3.

To do this, any dependencies of the command may need to be converted as well as the command itself.

[1] https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/toolkit/components/telemetry/tests/marionette/mach_commands.py

Assignee: nobody → rpierzina
Severity: -- → N/A
Priority: -- → P1
Depends on: 1559976

We're blocked on Python 3 support in marionette driver.

Once https://phabricator.services.mozilla.com/D108828 lands, this will be the last command to be converted :).

I took a stab at converting it, but the tests hit timeouts under Python 3 (with no obvious errors reported). Raphael, do you think you'll have a chance to look into this sometime soon? Are the timeouts what you were talking about in comment 1? And if so, who would be best to fix marionette driver? Thanks!

Flags: needinfo?(rpierzina)
Keywords: leave-open

I am currently testing D108834 locally. When I run ./mach telemetry-tests-client the imports seem to be resolved just fine, but the browser hangs and the test suite eventually fails with the following error:

IOError: Process killed after 120s because no connection to Marionette server could be established. Check gecko.log for errors

The gecko.log file contains the following lines, which I can't seem to find on a recent central checkout:

1616075482644	Marionette	INFO	Listening on port 2828
1616075482682	Toolkit.Telemetry	TRACE	TelemetryController::observe - app-startup notified.
JavaScript error: chrome://marionette/content/driver.js, line 136: NS_ERROR_FILE_NOT_FOUND:

I rebased patch D108834 locally to a recent a central checkout and all 9 tests passed via python2 ./mach telemetry-tests-client.

Attachment #9209833 - Attachment is obsolete: true

Comment on attachment 9210321 [details]
Bug 1638991 - [ci] Run telemetry-tests-client tests with Python 3, r?raphael

Revision D109084 was moved to bug 1699757. Setting attachment 9210321 [details] to obsolete.

Attachment #9210321 - Attachment is obsolete: true

Clearing the ni request here since we're discussing on the Phabricator patches.

Flags: needinfo?(rpierzina)
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/92a28262af54
[telemetry-tests-client] Ensure wptserve logs are included in our logger, r=raphael
https://hg.mozilla.org/integration/autoland/rev/f91acacf9df7
[telemetry-tests-client] Green up the tests on Python 3, r=raphael
https://hg.mozilla.org/integration/autoland/rev/cbdac2bc544f
[mach] Run ./mach telemetry-tests-client with Python 3, r=raphael
Pushed by abutkovits@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfe565378798
WIP: Bug 1638991 - [telemetry-tests-client] Don't use relative imports in telemetry_harness. CLOSED TREE
Status: NEW → RESOLVED
Closed: 20 days ago
Keywords: leave-open
Resolution: --- → FIXED
Regressions: 1704191
You need to log in before you can comment on or make changes to this bug.