Closed Bug 1638996 Opened 11 months ago Closed 4 months ago

Convert 'mach web-platform-tests' to run with Python 3

Categories

(Testing :: web-platform-tests, task)

task

Tracking

(firefox86 fixed)

RESOLVED FIXED
86 Branch
Tracking Status
firefox86 --- fixed

People

(Reporter: KrisWright, Assigned: hamzah18051)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

mach web-platform-tests still runs with python 2 [1]. We want to convert all mach commands to python 3.

To do this, any dependencies of the command may need to be converted as well as the command itself.

[1] https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/testing/web-platform/mach_commands.py

Assignee: nobody → hamzah18051
Status: NEW → ASSIGNED
Duplicate of this bug: 1639001
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/4e84834674a3
Run wpt mach commands under Python 3, r=karlcow
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
You need to log in before you can comment on or make changes to this bug.