Closed Bug 1639053 Opened 5 months ago Closed 4 months ago

Remove the ability to reverse flex container's axes internally

Categories

(Core :: Layout: Flexbox, task)

task

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: TYLin, Assigned: TYLin)

References

Details

Attachments

(1 file)

It was added in bug 983427 for aiding pagination work, but it turns out not being used in flex container's fragments (as of the patches in bug 1622935). Removing it can simplify various logic a bit.

Component: Layout → Layout: Flexbox
Summary: Remove the ability to reverse flex containers axes internally → Remove the ability to reverse flex container's axes internally

The ability to reverse axes internally was added in bug 983427, but it
turns out not to be used.

test_flex_lines.html needs to be modified because those expected cross
values are written as if the flex lines are physically in top-to-bottom
order (due to we reversed the axes internally).

Now we don't reverse the internal axes, the order of the flex lines
becomes bottom-to-top due to "flex-wrap: wrap-reverse". The crossStart
coordinate begins from the flex container's bottom end edge, and it
increases from bottom to the top to the flex container's top end
edge. (Note the flex container has 42px height.)

Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1ce1f7104af9
Remove the ability to reverse axes internally for nsFlexContainerFrame. r=dholbert
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Duplicate of this bug: 1000359
You need to log in before you can comment on or make changes to this bug.