Closed Bug 1639095 Opened 8 months ago Closed 5 months ago

Re-remove allowLinkedWebInFileUriProcess

Categories

(Core :: DOM: Content Processes, task, P3)

task

Tracking

()

RESOLVED FIXED
82 Branch
Fission Milestone Future
Tracking Status
firefox82 --- fixed

People

(Reporter: pbone, Assigned: pbone)

References

Details

Attachments

(1 file)

In Bug 1603007 we removed the allowLinkedWebInFileUriProcess pref. But this caused several regressions so we've re-introduced a similar behaviour in Bug 1634779. We still want to remove that code and we can do so after Bug 1550571 lands.

Most likely all we need to remove are the changes to E10SUtils.jsm that Bug 1634779 added.

The original "Remove allowLinkedWebInFileUriProcess" bug 1603007 was a Fission Future bug and thus not a Fission MVP blocker. But since we've had some regressions from bug 1603007, perhaps we should remove allowLinkedWebInFileUriProcess for good now, while it's still paged into Paul's head?

Fission Milestone: --- → ?
Priority: -- → P3

I'm going to put it in Future because in terms of delivering Fission it's not important. But that doesn't mean I can't do it sooner if it's convenient.

Fission Milestone: ? → Future

Depends on D77764

Assignee: nobody → pbone
Status: NEW → ASSIGNED
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/31524d1785a2
Re-remove allowLinkedWebInFileUriProcess r=kmag

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:pbone, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(pbone)

It's blocked on Bug 1650979.

Depends on: 1650979
Flags: needinfo?(pbone)
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4084e6a07381
Re-remove allowLinkedWebInFileUriProcess r=kmag
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
You need to log in before you can comment on or make changes to this bug.