If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't checkout after adding to shopping cart

RESOLVED DUPLICATE of bug 162902

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 162902
15 years ago
15 years ago

People

(Reporter: Will Nuzum, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
This site is used for purchasing savings bonds, but for some reason in Mozilla 
1.0 (and Netscape 7 PR1) after adding a bond to the shopping cart I can't 
proceed to checkout.  The 'Edit' and 'Delete' buttons both work, but the 
buttons to add more bonds, empty the cart, and checkout will not.  This works 
fine in Netscape 6.x

To test you can enter any dummy information in the first page (one letter 
names, only the state and zip must match)  This site doesn't use Javascript in 
order to meet standards set by section 508 of the Americans with Disabilities 
Act.  Any thoughts?

Comment 1

15 years ago
Confirming a problem on the trunk 20020930 -- but I don't know whether it's a
mozilla problem or a website problem.  If you are the website designer, could
you check and see whether mozilla is posting the proper pair btnShopMore=MORE
when you click the "Shop More" button?  I will try to test it on my local server
when I get a chance.
Assignee: asa → alexsavulov
Status: UNCONFIRMED → NEW
Component: Browser-General → Form Submission
Ever confirmed: true
QA Contact: asa → vladimire
(Reporter)

Comment 2

15 years ago
It is posting btnShopMore=MORE in addition to the button coordinates since the 
button is an image.  We're checking for the coordinate as well as the value.  
I'm going to look into removing the 'MORE' value from the button to see if that 
helps as the Delete and Edit buttons do work on that page, but don't have value 
attributes.
 

Comment 3

15 years ago
I don't know how much control you have over that server, but it would help if
you had access to the web logs, and these contained the full HTTP POST information:

submit the form using a browser that works (NS6.x, IE)... then under the same
conditions submit the form using a new mozilla build or NS7.  Check the logs to
see how the HTTP POSTdata differs.

Comment 4

15 years ago
Looks like dupe of 162902

*** This bug has been marked as a duplicate of 162902 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.