Can't send a mail with a JA mail list

RESOLVED WORKSFORME

Status

MailNews Core
Internationalization
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: Jeesun Cho, Assigned: m_kato)

Tracking

({intl})

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Can't send a mail with a JA mail list
Platform: Mac OSX

Steps:
1. In your Address Book, create a mail list and give it a JA name 
2. Include a card in that mail list
3. Put the JA list name in the recipient field of compose window and make sure
it's auto-completed and recognized as a list
4. Send your mail. (I used IMAP account)
5. You'll see an error:
An error occurred while sending mail. The mail server responded: Invalid address
syntax. Please check the message recipients and try again.

Note: On windows, sending from the same IMAP server with the same list name (and
everything) is working fine. I only see this on Mac platform
(Reporter)

Updated

16 years ago
Keywords: intl
QA Contact: marina → jeesun

Comment 1

16 years ago
Jeesun, i tried your steps but the mail was sent without an error. I tried POP,
IMAP with various combinations: higlighting the list, opening a new composition
and typing the list name and in both cases i didn't get any error
(Reporter)

Comment 2

16 years ago
I'll try this again. It was always reproducible for me on the Mac only. 
(Reporter)

Comment 3

16 years ago
Marina, Could you try this again?
I still see this on 0822 branch build.
I used mac osx and  used さんぽ (sanpo-see this in shift_jis) for the name of
mail list. I included two cards which have also JA names.

Comment 4

16 years ago
Jeesun, i just tried it again and it still works for me, i'll attach the screen
shot where you'll see the japanese list name (using iso-2022 and shift-jis) that
i used for testing

Comment 5

16 years ago
Created attachment 96379 [details]
this is a screen shot of the testing Address Book
(Reporter)

Comment 6

16 years ago
Hmmmm.... it's weird. It's not working for me. Well... I'll pass this for now
and look into it later

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 7

16 years ago
I have a similar problem using Chinese with Mozilla 1.2B on Linux (Redhat-6.2). 

Steps:
1. Open compose window.
2. In To: field input "&#23431; <joe@numa.com.tw>" (Chinese Big5 encoding)
3. Send the message. (I'm using SMTP account)
4. Error message:
   An error occurred while sending mail. The mail server responded: 5.1.1
<"e.<joe\"@numa.com.tw>"> User unknown. Please check the message recipients and
try again.

In step 2, delete the Chinese character then the mail can be sent correctly.
Also, using other Chinese character is OK. Seems some character will cause
mozilla to generate wrong recipient list.

Should I file another bug regarding this?

Comment 8

16 years ago
Seems the character is translated to Unicode :o

Also, sending mail with that character works fine in Mozilla 1.1. 

Comment 9

16 years ago
It seems my problem is the same with this one. The bug I reported was caused by
the modification of bug 168269.
(Reporter)

Comment 10

16 years ago
Kasumi and Marina,
Could you try this again? 
Please make sure that you open a new compose window and type a list name with JA
chars and send mail on native mac osx.

Comment 11

16 years ago
Jeesun, what do you mean "native MACOSX". Do you have one? I am localizing it
through the System Preferences.
(Reporter)

Comment 12

16 years ago
Marina,
Yes. that's what I meant:  Mac OSX with Japanese encoding as a system encoding.

Comment 13

16 years ago
with 2002-12-02-10 build on MacOSX i had no problem sending email with JA list
name. I typed it into the "To" foeld, waited till it autocompletes and clicked
send. MacOSX with ja locale, IMAP server. It WFM
(Reporter)

Comment 14

16 years ago
Thanks for trying this, Marina.
Let me do this again with a new build later. It never worked for me only on Mac
OSX. Don't know why.... :-)

Comment 15

16 years ago
No problem to me.
tested on 2002-11-20-16-1.0-JA
Mac OSX JA(pure JA)
IMAP, Netscape Webmail, AOL アカウント
List name: さんぽリスト
containing card name: さんぽ サンポ
              さんぽめーる サンポメール
                      さんぽAOL サンポAOL    

Comment 16

16 years ago
changing qa contact
QA Contact: jeesun → marina
Product: MailNews → Core

Comment 17

14 years ago
both naoki and I are off mozilla for about 20 monthes. If these bugs are still
here, the real status is 'wont fix'. If you want to reopen it, please find a
better owner who really looking at the bug database now. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 18

14 years ago
Mass Reassign Please excuse the spam
Assignee: nhottanscp → nobody

Comment 19

14 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 20

14 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
Product: Core → MailNews Core
QA Contact: marina → i18n
(Assignee)

Comment 21

8 years ago
Not reproduce on 3.1 (20100405).  Also it is tested on comment #15.
mark as WFM.
Assignee: jshin1987 → m_kato
Status: NEW → RESOLVED
Last Resolved: 14 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.