Closed Bug 1639341 Opened 3 months ago Closed 3 months ago

Build breakage unless MOZ_WAYLAND is defined

Categories

(Firefox Build System :: General, defect)

Unspecified
Linux
defect

Tracking

(firefox-esr68 unaffected, firefox76 unaffected, firefox77 unaffected, firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- fixed

People

(Reporter: rstewart, Assigned: stransky)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1635718 introduced a call to a pref that is only available #if defined(MOZ_WAYLAND), which is not necessarily the case. The call to widget_use_xdg_desktop_portal() should only be done if that variable is defined.

This unconditionally breaks my local Ubuntu builds unless I revert the offending commit.

43:11.44 /home/rstewart/src/mozilla-unified/toolkit/system/gnome/nsGIOService.cpp:42:32: error: no member named 'widget_use_xdg_desktop_portal' in namespace 'mozilla::StaticPrefs'
43:11.44   return mozilla::StaticPrefs::widget_use_xdg_desktop_portal()
43:11.45          ~~~~~~~~~~~~~~~~~~~~~~^
43:11.59 1 error generated.
Flags: needinfo?(stransky)
Flags: needinfo?(jhorak)
Duplicate of this bug: 1639353

Sorry for the breakage, I'll look at it.

Assignee: nobody → stransky
Flags: needinfo?(stransky)
Duplicate of this bug: 1639647
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bed5ad4ae80b
[Linux] Ship widget.use-xdg-desktop-portal on Gtk/Linux, r=jhorak
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Flags: needinfo?(jhorak)
You need to log in before you can comment on or make changes to this bug.