Alert if download in progress before system reboot

RESOLVED DUPLICATE of bug 28385

Status

--
minor
RESOLVED DUPLICATE of bug 28385
17 years ago
12 years ago

People

(Reporter: rsantmann, Unassigned)

Tracking

Trunk
All
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020821
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020821

When clicking Start->Shutdown the machine reboots, even if there is a large file
download in progress. Ideally this would be a prompt asking you "Are you sure
you want to reboot, there are downloads in progress?" I can't say how many times
I'll be downloading a 1 GB file and be 90% done when I forget about it and reboot.

Reproducible: Always

Steps to Reproduce:
1.Begin downloading a large file
2.Try to reboot windows
Actual Results:  
Download is cancelled and machine reboots.

Expected Results:  
Show a pop-up telling you there are downloads in progress and ask you if you are
certian you wish to reboot.

Comment 1

17 years ago
Personally I think this is silly, but personal feelings asside this is dependant
upon bug 28385 getting fixed. Then you could hook an endtask request up to this
system though I'm slightly worried this may affect being able to force mozilla
to close. Either way marking dependant upon 28385, then this can get looked at.
Depends on: 28385
QA Contact: sairuh → petersen

Comment 2

16 years ago
Setting OS to windows 2000 (reporter's platform) rather than "all". Unix
applications don't get to veto a system shutdown.
OS: All → Windows 2000

Comment 3

16 years ago
Confirming.
Summary: Auto-Cancel Download on Reboot Message → Alert if download in progress before system reboot
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: firefox → download-manager
QA Contact: chrispetersen
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

13 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 28385
You need to log in before you can comment on or make changes to this bug.