Password Manager doesn't always remember hotmail accounts

VERIFIED WONTFIX

Status

SeaMonkey
Passwords & Permissions
VERIFIED WONTFIX
16 years ago
14 years ago

People

(Reporter: Randy Santmann, Assigned: Stephen P. Morse)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020821
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020821

Hotmail.com does not correctly remember all of the mail accounts all of the
time. I think I have figured out why. I have multiple saved passwords for
hotmail.com

There is more than one server for passport log in
Example:
lc1.law5.hotmail.passport.com
lc2.law13.hotmail.passport.com
lc3.law13.hotmail.passport.com

So I must tell the Password Manager to remember my log in for all three servers
manually (there are probably more than three but bare with me), even though the
end user only sees hotmail.com; this makes it appear as if Mozilla is forgetting
the passwords.

Reproducible: Sometimes

Steps to Reproduce:
1.Go to hotmail.com
2.Tell it to remember the passport log in
3.Log in to the account
4.Log out
5.Go to hotmail.com
6.It may (or may not) ask for your password again, even though it was already
saved. See explaination as to why under "Details"

Actual Results:  
Does not remember password consistently.

Expected Results:  
Obvious.
(Assignee)

Comment 1

16 years ago
Yes, that's true.  And by design.  If I did otherwise you might have the case
where passwords from one host were being used by a different one resulting in
password stealing.  So this is the fail safe approach.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 2

16 years ago
Verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
Isn't there a way mozilla could check to see the end URL (see that it ends in
".hotmail.passport.com")? The only reason is it's annoying, because I check
hotmail on three computers, and...me and my "two friends"... have a total of
three hotmail accounts. Meaning 3x3=9 and I always find myself typing in
passwords (between that and Yahoo).
(Reporter)

Comment 4

16 years ago
Err sorry... I mean 3 hotmail x 3 servers x 3 computers = 27 times typing passwords.

Comment 5

16 years ago
isn't this a dupe of bug 92966 ?
(Reporter)

Comment 6

16 years ago
Yes.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.