Closed Bug 1639739 Opened 3 years ago Closed 2 years ago

Add Fission status to about:support's Decision Log, including why it is or is not enabled

Categories

(Core :: DOM: Content Processes, task, P3)

task

Tracking

()

RESOLVED FIXED
83 Branch
Fission Milestone M6b
Tracking Status
firefox83 --- fixed

People

(Reporter: cpeterson, Assigned: kmag)

References

Details

Attachments

(1 file)

about:support already lists “fission.autostart” pref (when true). We should add a more descriptive status to about:support's Decision Log describing why Fission is or is not enabled. Some reasons are:

  • Fission is disabled or enabled by the fission.autostart pref.
  • Fission was enabled by an experiment. (A Fission experiment might use a separate pref.)
  • Fission is disabled because the user doesn't meet some eligibility requirement, such as WebRender.
Fission Milestone: M6b → M6c
Fission Milestone: M6c → M6b

Andrew, maybe you can work on this?

Flags: needinfo?(continuation)

I don't think I'll have time to work on this. It looks quite involved.

For anybody who is working on this, bug 1632259 looks like it might be a useful start to investigate what exactly the decision log is, and what sort of underlying structures are needed to support it.

Flags: needinfo?(continuation)
Assignee: nobody → kmaglione+bmo
Status: NEW → ASSIGNED

kmag will add the C++ part to add pref info in services.appinfo in bug 1660057. Jared, can you then help with adding the appropriate info in about:support decision log?

Assignee: kmaglione+bmo → nobody
Status: ASSIGNED → NEW
Depends on: 1660057
Flags: needinfo?(jaws)

Confirmed with jaws to assign to him (thanks!).

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Depends on: 1667426
Depends on: 1669538

jaws doesn't have time to implement this so requesting kmag to do this. :)

Assignee: jaws → kmaglione+bmo
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d09eaeb692ee
Add Fission decision status to about:support. r=nika,fluent-reviewers,Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
You need to log in before you can comment on or make changes to this bug.