Closed Bug 16398 Opened 21 years ago Closed 21 years ago

Support format=flowed (RFC 2646) in mail

Categories

(MailNews Core :: Composition, enhancement, P3)

x86
All
enhancement

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bratell, Assigned: bratell)

References

()

Details

Attachments

(5 files)

In Eudora (later versions) a format "flowed" is used to tell the client that
even though the text is wordwrapped, it is one paragraph and one should be able
to change linebreaks to avoid things like:

> Really Really Really Really Really Really Really Really
> long
> row that is an example of the stupid linebreaks caused by
> rows
> getting longer when quoting.

One could use HTML to avoid this but flowed is a better idea since it also makes
the message readable as plain text.

I'm not into all details in the format but I could research it if you think it's
an interesting idea.

What I do know (by looking at messages sent by Eudora) is that they have a
special content-type, for instance:

Content-Type: text/plain; charset="iso-8859-1"; format=flowed
Content-Type: text/plain; format=flowed
or
Content-Type: text/plain; charset="us-ascii"; format=flowed

you see the pattern?


I also thinks Hotmail does this.

(Please change the component to a more appropriate, I just guessed.)
Status: NEW → ASSIGNED
Summary: Support flowed as Eudora (and others) uses. → [Feature?]Support flowed as Eudora (and others) uses.
Target Milestone: M15
Assignee: ducarroz → nobody
Status: ASSIGNED → NEW
Summary: [Feature?]Support flowed as Eudora (and others) uses. → [HELP WANTED][Feature] Support flowed as Eudora (and others) uses.
Whiteboard: [HELP WANTED]
Target Milestone: M15
Adding to [HELP WANTED] list and reassigning to nobody@mozilla.org
Summary: [HELP WANTED][Feature] Support flowed as Eudora (and others) uses. → [HELP WANTED][Feature] Support format=flowed as Eudora (and others) uses.
I found the specification at
ftp://ftp.ietf.org/internet-drafts/draft-gellens-format-06.txt

It's a good thing and I would really like to see it in mozilla. I will look at
this but I don't think I can find the time anytime soon. Is the mime converters
a good place to start?
Assignee: nobody → bratell
Ok, I want to work on this. Assigning the bug to myself.
By the way, it is no longer a draft. See RFC 2646.
Attached file The headerfile
I attached a libmime class that should make it possible to view format=flowed
mails in the enhanced way. Feel free to test and give me feedback.
By the way. To implement this in mozilla would be a possible solution to bug
2916.
Status: NEW → ASSIGNED
The first half (approximately the part in the attachments) checked in by
rhp@netscape.com. (Yes, I confess, I'm the nameless external contributor
mentioned. :-)
Just to clarify. I've only done the format=flowed-support part. The new
MimeURLUtils is not something I been involved in.
Daniel Bratell,
work collosion. You changed major parts of nsHTMLToTXTSinkStream, while I was
working on it (and mad large changes), too. Please stop working at least on that
class until I merged the changes. Thanks. Akk knows about it.
see bugs #16507 and 16800
Depends on: 17723
OS: Windows NT → All
Daniel,
sorry if I sounded bad in my last comment. I was just a bit frustrated.

Unfortunately, I will need some time, until I finish bug #17723 (added as
dependency). Are there still things to do for you in the sink
(nsHTMLToTXTSinkStream)? Is yes, please tell me, so we can find a solution.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Summary: [HELP WANTED][Feature] Support format=flowed as Eudora (and others) uses. → Support format=flowed (RFC 2646) in mail
Whiteboard: [HELP WANTED] → Checked in.
Target Milestone: M11
With todays checkin (done by Akkana) it should both be possible to send mail
with format=flowed (It's controlled with a pref mailnews.send_plaintext_flowed)
and read format=flowed mail in mozilla.
No longer depends on: 17723
QA Contact: lchiang → pmock
changing qa assigned to pmock@netscape.com
Whiteboard: Checked in. → having difficulty verifying bug - need help
I sent a e-mail to Daniel asking for his help.  I wrote:
----
Subject: Need help understanding the fix for bug 16398
Date: Tue, 04 Jan 2000 14:24:43 -0800
From: pmock@netscape.com (Peter Mock)
To: bratell@lysator.liu.se
CC: rhp@netscape.com

Hello Daniel,

I attempting to verify bug 16398 "Support format=flowed (RFC 2646) in
mail", but I'm having difficult getting this feature to work.  By
default, any plain text message that is sent has the message
content-type set with format=flow, I have been unsuccessful in getting
the text to flow as specified in RFC 2646.  I've tried to
enabling/disabling the preference mailnews.send_plaintext_flowed and
read format=flowed mail but with no results.  Is this the correct user
preference?

Could you confirm if this feature is still working for you?  I noticed
that mozilla@bucksch.org is working on bug 17723 which share some of the
same code.

Thank you for your help.
/Peter
 Client Mail QA
Reopening, because plain text mail is no longer composed as format=flowed. The 
mails are marked as such, but they are not. There are several other problems 
with plain text composing of mail that may be related to this. There is also 
some problems with the conversion from html to plain text. It is as the mail is 
line wrapped after the conversion even though it is line wrapped already in the 
conversion. As the mail is sent as Quoted Printable the lines has hot a little 
longer so the line wrapping gets strange.

Reading format=flowed mails still works though. 
Status: RESOLVED → REOPENED
Target Milestone: M11 → M14
Clearing resolution.
Resolution: FIXED → ---
Thank you Daniel for reviewing this bug. :)
CC'ed nhotta and myself.
Blocks: 26734
When composing with plaintext the outputsink was initialized with mPreFormatted, 
nsIDocumentEncoder::OutputPreformatted and nsIDocumentEncoder::OutputFormatted. 
That combination went through the "just emit what comes in"-path and was 
neither wrapped nor formatted for "format=flowed". I've tried to change so that 
combination goes through the intelligent code path, but I have no idea if that 
breaks anything else. I'll attach the patch for testing.
Added John M. to CC.
Depends on: 26904
Target Milestone: M14 → M15
Well, it works now. It must have been a temporary thing elsewehere in the code. 
I'll close this as FIXED again.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Verified as fixed on Windows, Linux and Mac using the following:
 Windows commercial seamonkey build 2000-060909-m17 installed on PIII win98
 Linux commercial seamonkey build 2000-060908-m17 installed on PII RedHat 6.1
 MacOS commercial seamonkey build 2000-060908-m17 installed on G3/400 OS 9.04
Status: RESOLVED → VERIFIED
Forgot to clear status on whiteboard.
Whiteboard: having difficulty verifying bug - need help
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.