URL bar should have focus when creating a new blank tab

VERIFIED DUPLICATE of bug 162001

Status

Camino Graveyard
Tabbed Browsing
VERIFIED DUPLICATE of bug 162001
16 years ago
16 years ago

People

(Reporter: Wincent Colaiuta, Assigned: Simon Fraser)

Tracking

Details

(Reporter)

Description

16 years ago
When the user creates a new tab by hitting command-T, or by choosing "New tab"
from the File menu, the URL should have the focus so that they can type in a new
location.

Expected behaviour: on creating a new blank tab, the URL bar should have the
focus so that the user can type in a new location.

Actual behaviour: if the URL bar had the focus at the time the user created the
new tab then it retains focus and there is no problem, but if another tab or
element had the focus then the URL bar does not receive focus.

This problem is related to another bug (which I can't find right now) about the
ability to use tab to switch focus between a tab and the URL bar: the current
bug wouldn't be so bad if you could hit tab to bring the URL bar into focus, but
you can't...
i think this is a dupe of one simon already has
Assignee: pinkerton → sfraser

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 162001 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.