Closed Bug 1640109 Opened 4 months ago Closed 4 months ago

Account screen - actions button wrapping

Categories

(Thunderbird :: Theme, defect)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 78.0

People

(Reporter: paully.littlefield, Assigned: aleca)

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.61 Safari/537.36

Steps to reproduce:

Started Thunderbird and selected email account on left to show account summary window on right.

Actual results:

On higher resolution screens, the account option 'End-to-end Encryption' is not on the same line as the other options for 'Read Mesages' and 'Manage Message Filters' etc.

Expected results:

On higher resolution screens, the account option 'End-to-end Encryption' should be on the same line as the other options for 'Read Mesages' and 'Manage Message Filters' etc.

This is proven by the fact that when you resize the main TB window, the options buttons wrap as expected.

(Is there a fixed width setting going on here?)

This is what happens when you make the TB window smaller.

(Is there a fixed width setting going on here?)

There is, it's a 800px max-width that was initially introduced to wrap that section into 2 columns since we were listing around 10 option links.
We reduced the amount of links to remove redundancy and clean up the area, so the maximum number that might be visible at the same time is 5.

I think it's OK to remove the max-width.

Assignee: nobody → alessandro
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9151105 - Flags: review?(richard.marti)
Comment on attachment 9151105 [details] [diff] [review]
1640109-account-manager.diff

Yes, the account buttons below do also go the whole width and it looks weird when this  options wrap earlier.
Attachment #9151105 - Flags: review?(richard.marti) → review+
Target Milestone: --- → Thunderbird 78.0

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/b785d5738e79
Remove max-width from Account Manager options container. r=paenglab DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

Fabulous, thanks :-)

Fixed in Thunderbird 78.0b1

Thank you!

:-)

Paully

You need to log in before you can comment on or make changes to this bug.