Closed Bug 1640171 Opened 11 months ago Closed 11 months ago

applink-fenix and applink-gv tasks fail always

Categories

(Testing :: mozperftest, defect, P1)

defect

Tracking

(firefox-esr68 unaffected, firefox76 unaffected, firefox77 unaffected, firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- fixed

People

(Reporter: aryx, Assigned: sparky)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

The applink tasks permafail.

This seems to be from bug 1638001 and its _test_info path.

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=303086208&repo=mozilla-central

[task 2020-05-20T13:28:15.040Z] Traceback (most recent call last):
[task 2020-05-20T13:28:15.040Z] File "python/mozperftest/mozperftest/runner.py", line 170, in <module>
[task 2020-05-20T13:28:15.040Z] sys.exit(main())
[task 2020-05-20T13:28:15.040Z] File "python/mozperftest/mozperftest/runner.py", line 166, in main
[task 2020-05-20T13:28:15.040Z] run_tests(mach_cmd, **dict(args._get_kwargs()))
[task 2020-05-20T13:28:15.040Z] File "python/mozperftest/mozperftest/runner.py", line 140, in run_tests
[task 2020-05-20T13:28:15.040Z] e.run(metadata)
[task 2020-05-20T13:28:15.040Z] File "/builds/worker/checkouts/gecko/python/mozperftest/mozperftest/environment.py", line 89, in run
[task 2020-05-20T13:28:15.040Z] metadata = layer(metadata)
[task 2020-05-20T13:28:15.040Z] File "/builds/worker/checkouts/gecko/python/mozperftest/mozperftest/layers.py", line 120, in call
[task 2020-05-20T13:28:15.040Z] metadata = layer(metadata)
[task 2020-05-20T13:28:15.040Z] File "/builds/worker/checkouts/gecko/python/mozperftest/mozperftest/browser/browsertime/runner.py", line 312, in call
[task 2020-05-20T13:28:15.040Z] metadata = self._one_cycle(metadata, result_dir)
[task 2020-05-20T13:28:15.040Z] File "/builds/worker/checkouts/gecko/python/mozperftest/mozperftest/browser/browsertime/runner.py", line 352, in _one_cycle
[task 2020-05-20T13:28:15.040Z] self.info("Running browsertime with this command %s" % " ".join(command))
[task 2020-05-20T13:28:15.040Z] TypeError: sequence item 12: expected str instance, PosixPath found

Flags: needinfo?
Flags: needinfo? → needinfo?(gmierz2)

This patch fixes a bug where a PosixPath is attempted to be used rather than a string path. There's also a regression in the coverage test run in ./mach perftest-test on some platforms that is fixed by this patch (the attrs module being used by pytest is too old, so we update during setup). Lastly, a regression test is added to the browsertime tests to ensure that the command only contains knowingly compatible types.

Flags: needinfo?(gmierz2)
Regressed by: 1639212
No longer regressed by: 1638001
Assignee: tarek → gmierz2
Severity: -- → S1
Priority: -- → P1

This patch updates the vendored attrs python module from v18.1.0 to v19.1.0 since the older version fails in some pytest features.

slightly changed the patch in my try run (removed changes outside attrs)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3f38c0302bb4d87bb3d2ae54258328881fc164ad

Pushed by tziade@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c7cebdd58fc
Make the test file a str before using it. r=mozperftest-reviewers,tarek
https://hg.mozilla.org/integration/autoland/rev/8f2f5cb33285
Update vendored attrs python module to 19.1.0. r=tarek
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.