Closed Bug 1640249 Opened 4 months ago Closed 4 months ago

Fix the long tail of Python3 incompatibilities in Marionette

Categories

(Testing :: Marionette, defect)

defect

Tracking

(firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: bc, Assigned: bc)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Even after bug 1595814 lands, there are many Python3 incompatibilities remaining in Marionette. I have a work in progress to fix these.

marionette_driver/geckoinstance: basestring to str
marionette_harness/runner/base.py Python3 None is not comparable to int.
marionette testcases.py types.ClassType
marionette_driver/errors.py unicode to str conversion.
marionette - reraise must pass instance as 2nd arg.
marionette fixes from 2to3.
moar marionette fixes

Depends on D76494

Attachment #9151394 - Attachment description: Bug 1640249 - Make marionette to Python2/Python3 compatible. → Bug 1640249 - Make marionette Python2/Python3 compatible.
Duplicate of this bug: 1597745
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e35490feff3a
Make marionette Python2/Python3 compatible. r=marionette-reviewers,maja_zf,whimboo
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

fyi, while looking into awsy-test I found more Python3 issues with marionette. I'll finish up awsy-test and then re-visit marionette.

Duplicate of this bug: 1598323
Blocks: 1654537
You need to log in before you can comment on or make changes to this bug.