Closed Bug 1640298 Opened 4 months ago Closed 4 months ago

perma Android 8.0 AArch tests/jit-test/jit-test/tests/baseline/bug847425.js | Segmentation fault (code 139, args "") [0.3 s] when Gecko 78 merges to Beta on 2020-06-01

Categories

(Core :: JavaScript Engine, defect)

defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 + verified

People

(Reporter: aryx, Assigned: jandem)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Both the simulations of central-as-early-beta and central-as-late-beta hit this segmentation fault on android-hw-p2-8-0-android-aarch64-shippable opt today:

Early Beta
Late Beta

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=303387175&repo=try

TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/baseline/bug847425.js | Segmentation fault (code 139, args "") [0.3 s]
TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/baseline/bug847425.js | Segmentation fault (code 139, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.3 s]
TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/baseline/bug847425.js | Segmentation fault (code 139, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]

Could this be related to bug 1623355?

Jan, as author of the test from bug 847425: Any idea why this is segfaulting?

Flags: needinfo?(jdemooij)

Update: this is probably an OOM crash of some sort that's ~impossible to analyze without a backtrace or way to reproduce locally. I asked Aryx if we can bisect this in case that tells us something and he's working on that now.

This starts with the changes from bug 1637529.

Regressed by: 1637529

Jon, any idea what could be happening? The test doesn't use modules but maybe there's some new code that runs anyway? It could also just be caused by differences in the GC heap...

Flags: needinfo?(jdemooij) → needinfo?(jcoppeard)

Oh bah, this looks like bug 1532654. Needs the same workaround as in bug 1545537.

Flags: needinfo?(jcoppeard) → needinfo?(jdemooij)
Flags: needinfo?(jdemooij)
Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
See Also: → 1532654
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60e97654bef3
Disable bug847425.js jit-test on Android due to harness problems. r=tcampbell
No longer regressed by: 1637529
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.