hiliting text in Location or other text boxes erratic

CLOSED WORKSFORME

Status

()

Core
Selection
P3
normal
CLOSED WORKSFORME
19 years ago
19 years ago

People

(Reporter: WD, Assigned: mjudge)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
when I try to double-click on the location text box, Mozilla build 1999101312
Does not usually hilite the entire text box.     The results are very erratic.
 I also have trouble when manually trying to hilite a portion or all of a text
box with the mouse.   (by holding down the left mouse button and dragging)

This behavior happens with any text box on the screen, also.

Comment 1

19 years ago
wdormann@crosswinds.net, what OS are you using? Are you possibly moving the mouse
slightly while double-clicking? What do you mean by "erratic"?

In the future, please consider reading and following the Bug Writing Guidelines,
located at http://www.mozilla.org/quality/bug-writing-guidelines.html. Thanks!

---

mjudge, we definitely have no sensitivity to slight mouse movements that occur as
part of the second mouse click in a double click gesture, unlike other apps. Is
this a schedule item, or should we use this bug to track it, or...?

Thanks!
Assignee: don → mjudge
Component: Browser-General → Selection
QA Contact: leger → elig
(Reporter)

Comment 2

19 years ago
Hello!      I must apologize for the vague posting.   I'll try to clear things
up here.   Perhaps this should be split into several bug posts, but they all
have the same general idea.

Overview Description -    When trying to hilite text in a Mozilla textbox, such
as the location bar at the top, the results are not as expected.

Steps to Reproduce -

1)  Load up Mozilla.   Click in the whitespace following the location
"http://www.mozilla.org/"   (you will notice the blinking cursor appears at the
end of the trailing "/"

2) Next, click in that whitespace once again, and while holding the mouse button
down, move the mouse to the left, as to hilite the text in the location box.

3)  Next, try double-clicking in the whitespace, as to hilite the entire
location box text.

4)  Finally,  Try hiliting a secion of the location box.  (such as the "www")
It should hilite Ok.    But then try pressing the right arrow key a couple of
times.

Actual Results -    (corresponding to numbers above)
2)  Text does NOT hilite.   (nothing happens)
3)  Text does NOT hilite.   (nothing happens)
4)  A cursor "artifact" is left, immediately after the "www"

Expected Results -
2)  Text dragged over should hilite
3)  Entire text box (location box) should hilite
4)  No residual cursor artifact should be left

Build Date and Platform -
Mozilla build 1999101312
Win32 version Windows 98 (not SE)
Microsoft mouse with wheel

There may be other issues with the text boxes in Mozilla, but that's what I've
found in my few minutes of playing around with it.   I am not moving the mouse
when double-clicking or anything like that.   I'm just comparing it to the
Netscape or IE behavior that I'm used to.

-WD
(Reporter)

Updated

19 years ago
OS: other → Windows 98
(Reporter)

Comment 3

19 years ago
Ahh, yes...  there was one other case I forgot to mention.

5)  With the cursor at the beginning of the location text
"http://www.mozilla.org"   (or whatever), with the mouse button held down,
QUICKLY move the mouse to the left, as to hilite the whole text in the box.

Actual results:
Depending on how fast the mouse is moved, a subsection of the text will be
selected, such as "http://www.mozilla.o"    or "http://www.mozil"

Expected results:
Of course, the whole text should be selected


As I explained above, this problem also seems to be related to the handling of
the "whitespace" after the text.  It's as if it doesn't exist...  once the mouse
hits the whitespace, the hiliting stops...   If it hasn't hilited the entire
text by the time the whitespace is hit by the mouse, it stops.

-WD

Comment 4

19 years ago
wdormann@crosswinds.net, thank you for the outstanding bug report follow-up!
Please accept a virtual Mozilla QA stamp of recognition. ;)

This doesn't sound like a duplicate of any issues that I know of. Mike?

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12

Comment 5

19 years ago
setting to M12 -- Mike, if this is similar to the other M15 selection clean-up
bugs then change milestone to M15, we should probably attack all of these
selection clean-up issues as a block of fixes.
(Reporter)

Comment 6

19 years ago
Just an update on this bug....

I just downloaded Mozilla Build 199101511 for my PC at home, and I have noticed
NONE of the above bugs.    The relevant differences between the PC's that I can
see:

Mine:
Win95 OSR2.1
Logitech Serial Mouse
ATI AIW 128 Video card w/ latest Lightspeed 2000 drivers

At Work:    (the one that doesn't work right)
Windows 98    (not SE)
Microsoft Intellimouse , PS/2 connector
STB Velocity 4400 (Riva TNT) video card

-WD
(Reporter)

Comment 7

19 years ago
Overview Description:

When first loading up Mozilla, if the Location box at the top is double-
clicked, the text (http://www.mozilla.org) is not selected.   A 2nd double-
click is required.

Steps to reproduce:
Load Up Mozilla
Double-click on the Location box

Actual results:
The cursor is moved from the beginning of the Location box to the end.  After a
subsequent double-click, the text is selected.

Expected results:
The entire text of the Location box is selected after the first double-click.

Build Date & Platform:
Mozilla build 1999110708
Windows 98

Additional information:
The previous text box anomalies described above this message do not seem to be
present in the current builds of Mozilla.  ("Erratic" hiliting, cursor
artifacts, etc..)
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

19 years ago
ok i just tried this on yesterdays build and it seems fine.  I tried it on win98
with a build from 10-03 and it DID reproduce the problems you are describing.  I
am therefore resolving this as "works for me".  If you reproduce this with a
more recent build please do reopen or make a new bug along with the steps to
reproduce. thanks alot keep up the good work!

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
wdormann@crosswinds.net, are you still seeing this on a current build? (e.g. from
within past 72 hours)

If so, could you please re-open? (just in case it is actually specific to a
driver or hardware configuration on your end)

Thanks!
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 10

19 years ago
I have downloaded the latest nightly build of Mozilla (1999121008), and it still
exhibits the above described behavior.    (having to double-click twice on the
location bar to hilite it after initially loading up Mozilla)

Granted, this bug is not the same as the original bug that I had opened up, and
maybe this has caused some confusion on whether or not the bug is resolved or
not.   Perhaps I should open a new bug with the information in my immediately
preceeding post?

Actually, I have some further information on the bug.   The bug appears to be a
"focus" problem.    (I'm not really a programmer, but I think that's what you'd
call it).      When Mozilla is initially loaded up, the location bar does not
have the cursor or mouse focus.     If I click on the location bar once to get
the focus, it will then hilite properly following a double click.

So actually, 2 double clicks are not required, but rather a single click and
then a double click.    After this point, the location box text hilites properly
with any double-click, no matter where the "focus".

(I hope this makes sense?)
-WD

Comment 11

19 years ago
If it's a separate bug from what it started with, yes, I agree that it would be
great if you could split it into a separate, new bug, and close this one out.

Thanks!
(Reporter)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
(Reporter)

Comment 12

19 years ago
Done.     This one's taken care of then.    It works for me.

-WD

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 13

19 years ago
Thanks! (BTW, could ya possibly insert the bug # for the new bug into this bug
when you submit it?)

See ya.
(Reporter)

Updated

19 years ago
Status: VERIFIED → CLOSED
(Reporter)

Comment 14

19 years ago
The new bug described in the text above is now re-listed as:

Bug 21450
You need to log in before you can comment on or make changes to this bug.