XHTML 1.0 td-height rendered incorrectly

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Ulrich Geyssel, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1) Gecko/20020417
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1) Gecko/20020417

In a layouttable there are images, touching each other.
The table border, cellpadding and cellspacing attributes are set to zero.
The td-height is set same as the included img-height.
Using
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN">
the td-height is rendered to big, leaving about 5px of the table/body-background.
IE 6 and NN 4.7 render correctly and Mozilla does so if I use
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">.

 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Reporter: this is fixed in 1.0.1 and 1.1, which should both be released Very
Soon Now.

You're using a very old version of Mozilla, and you were using 'standards' mode.
Mozilla now has an additional 'Almost Standards' mode which should trigger with
the XTML-transitional doctype. See
http://evolt.org/article/New_DOCTYPE_sniffing_in_upcoming_Mozilla_releases/1/32271/

Workaround : use <img src="..." style="display:block" />
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 2

16 years ago
 Verified works for me on the latest builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.