Scrolling drops out lines in the painted / layout page

RESOLVED DUPLICATE of bug 152671

Status

()

--
major
RESOLVED DUPLICATE of bug 152671
16 years ago
16 years ago

People

(Reporter: ochris1, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When scrolling with either the scroll bar or the mouse wheel
a single pixel line can be droped out.  Seems to be always from the
bottom as the text / image scrolls up.  Much worse when using the 
mouse wheel.  If you place the pointer in the middle of the page
and click once then go and click in the URL entry window the page
repaints and the missing pixel lines appear.  This is with a current
nightly build, but I have been having this problem for a LONG time 
with both release and nightly builds.

AMD x86
RedHat 7.2

Comment 1

16 years ago
I also have seen this to happen with Mozilla 1.1 (Debian packaged), and Mozilla
1.2a (compiled myself), but it has also appeared in previous releases; actually
in each that I have tried (i.e. greater than M-18), if I remember correctly.

The problem is that when scrolling down or up, some full width single pixel
horizontal lines are missing. This can also be seen on many pages, and sometimes
it does not require scrolling very much. This affects all the content on a web page.

Additionally, moving another window across the misdrawn portion causes it to be
correctly drawn.

Reproducibility: Always (mostly)
Steps to reproduce:
1. Go to e.g. http://users.utu.fi/lahtonen/rubik.html
2. Move to the top of the page.
3. Scroll down holding the down arrow key pressed.
4. When you reach the title "Ratkaisualgoritmi", or before, release the down arrow.

Actual results: Some horizontal single-pixel lines seem to have been randomly
dropped out, and the text looks messy. (I'll attach a screen shot.)

Expected results: Page should not have missing horizontal single pixel lines
when drawn.

Additional information:
AMD k6, 400 Hz
Linux 2.4.19, and also earlier kernel versions.
XFree86 4.2.1, 4.2.0, 4.1.0, 4.0, with SiS 530, or 4.2.0 and 4.2.1 with tdfx.

Comment 2

16 years ago
Created attachment 100137 [details]
A screen shot of the effect

At the top of the screen shot there are text lines, that miss some horizontal
single-pixel lines. When moving another window across these lines, the affected
portion of the page is drawn correctly.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 152671 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.