Closed Bug 1640589 Opened 2 years ago Closed 2 years ago

Open with Nightly option is not responding once a pdf was opened before with a third party

Categories

(Firefox :: File Handling, defect, P2)

78 Branch
All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- verified

People

(Reporter: Anca, Assigned: jaws)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screencast issue .gif

Affected versions

  • 78.0a1 (2020-05-24)

Affected platforms

  • Windows 10 x64

Steps to reproduce

  1. Set Nightly as PDF default at the OS level
  2. Set Portable Document Format (PDF) inside about:preferences to always ask
  3. Paste https://www.alumniweb.ox.ac.uk/jesus/file/Content_01_28_WEB-compressed-2.pdf inside the URL bar
  4. Chose a third party app (eg. Foxit Reader) from the Open with dropdown
  5. Paste https://www.alumniweb.ox.ac.uk/jesus/file/Content_01_28_WEB-compressed-2.pdf inside the URL bar again
  6. Choose Open with Nightly option

Expected result

  • The pdf opens in pdf.js

Actual result

  • The pdf content opens with the third party app

Regression range

Additional notes

  • “Open with” Applications\firox.exe(default), options inside Opening Content panel opens the content in Nightly
  • “Open with Nightly” works when Foxit Reader is set as default at OS level
Severity: -- → S3
Has STR: --- → yes
Has Regression Range: --- → yes

Set release status flags based on info from the regressing bug 773942

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: -- → P2
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/441ab3d24b2f
Update the mimeInfo when a download is handled internally. r=Gijs
Regressions: 1641774
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78

The issue is verified fixed with 78.0b2 and Fx 79.0a1(2020-06-03) on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.