Closed Bug 1640807 Opened 11 months ago Closed 11 months ago

Mailto link don't work

Categories

(GeckoView :: General, defect)

ARM
Android
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1596825

People

(Reporter: vtimisica, Unassigned)

Details

The bug was reported on Fenix: https://github.com/mozilla-mobile/fenix/issues/10391.

Found that there is a closed bug in bugzilla about this: https://bugzilla.mozilla.org/show_bug.cgi?id=1629243 but it is still reproducible, this is why I created a new issue.

Steps to reproduce

Expected behavior

  • Email app is opened, as it is in Fennec or Chrome

Actual behavior

  • Nothing happens

Additional info

Investigated this and found a mailto that works for Fenix (https://daleharvey.github.io/testapp/) and we have http://www.cfagirona.cat/ that doesn't work.

For the mailto that works, onLoadRequest from GeckoSession is called and then it propagates to AppLinksUseCases where context.startActivity is called.

For the mailto that does't work, onLoadRequest from GeckoSession is not called at all.

I also tested this in Reference Browser and it has the same behavior as Fenix(mailto from https://daleharvey.github.io/testapp/ works but the mailto from http://www.cfagirona.cat/ doesn't).

In Fennec it works well on all pages that I tested.

For GeckoViewExample app nothing happens when I tap on those links but I posted below the logs:

  • logs for the mailto that "works"
  • logs for the mailto that "doesn't work"

Hope I'm not wrong but I think is'a a GV bug.

This issue was resolved in bug 1596825 -- non-top-level navigation requests like this now come through on NavigationDelegate.onSubframeLoadRequest(), and I've confirmed it does for this particular case. Closing the bug as a dupe.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1596825
You need to log in before you can comment on or make changes to this bug.