Closed Bug 1640977 Opened 3 months ago Closed 2 months ago

Tidy ArenaLists class definition

Categories

(Core :: JavaScript: GC, task)

task

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: jonco, Assigned: jonco)

Details

Attachments

(2 files)

While working on bug 1508327 I made some small tidyups to the ArenaLists class.

The arenaLists() method returns an ArenaList, confusing when we also have an ArenaLists class, and arenaListsToSweep() returns an Arena. This gives them clearer names.

Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2348767fd355
Rename some ArenaLists members for clarity r=sfink
https://hg.mozilla.org/integration/autoland/rev/ff13d34e8f77
Tidy the ArenaLists class definition to put all data members in one place r=sfink
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.