Closed Bug 1641422 Opened 5 months ago Closed 4 months ago

TB77 Dark mode unreadable text in message reader/content pane

Categories

(Thunderbird :: Message Reader UI, defect)

defect

Tracking

(thunderbird78?)

RESOLVED DUPLICATE of bug 1639249
Tracking Status
thunderbird78 ? ---

People

(Reporter: bugzilla, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

Receive email in thunderbird beta

Actual results:

I'm running TB77.0b3 and the dark theme in the email content pane renders it almost unreadable in many cases, in particular when receiving email from Outlook users.

Outlook unfortunately chooses a blue #1f497d as the default text color on emails, and the resulting blue on dark grey is very difficult to read. It also chooses black for replies and that's even worse. It may be readable if your monitor is very bright, but it's still extremely low-contrast.

It looks like Outlook actually changes the color to a brighter blue and the black to white when its content pane is in dark mode. This text is all completely readable in Outlook.

In a related note, HTML emails that don't set their background color inherit the dark theme background and are very difficult to read as the text is black on dark grey.

Expected results:

I would suggest fixing it in a similar manner to outlook; lightening text colors to a certain threshold and just plain switching black text to white.

If that's a high LoE, is there any way to disable the dark background in the TB content pane, some about:config setting perhaps?

Attached image test email in TB77.jpg
Attached image broken_html_email.jpg

I can reproduce this on Mac, a lot of emails would be unreadable, so flagging for tracking.

Status: UNCONFIRMED → NEW
Component: Untriaged → Message Reader UI
Ever confirmed: true

Probably a regression from bug 1627748.

Regressed by: 1627748
Keywords: regression

(In reply to HK-47 from comment #0)

If that's a high LoE, is there any way to disable the dark background in the TB content pane, some about:config setting perhaps?

Outlook has a "switch to light background" button. Maybe implement a similar function to manually show the message pane with a light background without changing the app's whole theme.

Summary: TB77 Dark mode unreadable text in content pane → TB77 Dark mode unreadable text in message reader/content pane
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1639249
You need to log in before you can comment on or make changes to this bug.