Closed Bug 1641996 Opened 8 months ago Closed 8 months ago

Pinch-to-zoom doesn't zoom on second screen of a hybrid setup.

Categories

(Core :: Panning and Zooming, defect)

x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: mhoye, Assigned: tnikkel)

References

Details

Attachments

(2 files)

I've got a multimonitor setup, and when Firefox is on my touch-enabled screen, both the trackpad pinch and screen pinch work as expected, but when I put Firefox on the other non-touch-enabled monitor, screen pinch obviously doesn't work, but trackpad pinch also doesn't work.

My setup is, Surface Book 2 with precision trackpad and touchscreen, external monitor without touch capability, Win10 current as of today, Nightly same.

apz.windows.use_direct_manipulation and apz.allow_zooming are both set to true, and pinch to zoom works correctly, screen and touchpad, when Firefox is on the touch-enabled screen.

Component: Graphics → Panning and Zooming

Does it work in Chrome? Or Edge? Either Chromium based Edge or otherwise.

Flags: needinfo?(mhoye)

Also, does it work if the Firefox window is never on the touch screen? ie it starts it's life on the external monitor and is never moved.

I realized that my old Surface Pro 2 had a mini display port so I could use my tv as a external monitor and then hack the source to enable direct manipulation on windows 8 to reproduce this.

Flags: needinfo?(mhoye)

The problem is the mFocusPoint is in screen coords and should be relative to the widget. I was thrown off by this comment

https://searchfox.org/mozilla-central/rev/8827278483c337667cdfb238112eb1be397dd102/widget/InputData.h#471

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ac8ebdcda25b
Put the focus point of pinch events from Direct Manipulation in widget relative coordinates. r=kats
Attachment #9152914 - Attachment description: Bug 1641996. Put the focus point of pinch events from Direct Manipulation in widget relative coordinates. r?kats → Bug 1641996. Put the focus point of pinch events from Direct Manipulation in widget relative coordinates. r=kats
Flags: needinfo?(tnikkel)
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/65c72f5bd06f
Put the focus point of pinch events from Direct Manipulation in widget relative coordinates. r=kats

Depends on D77576

Thanks for testing and filing. Let us know if you see any more problems.

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Blocks: 1630912
You need to log in before you can comment on or make changes to this bug.