Mozilla crashes while trying to open http://www.blechdachs.de/test.html [fieldset with position:absolute]

RESOLVED DUPLICATE of bug 130251

Status

--
critical
RESOLVED DUPLICATE of bug 130251
16 years ago
14 years ago

People

(Reporter: Bernd.Bartmann, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530

Mozilla crashes while trying to open http://www.blechdachs.de/test.html


Reproducible: Always

Steps to Reproduce:
1. open http://www.blechdachs.de/test.html
2.
3.

Comment 1

16 years ago
WFM 2002082208/trunk/W2K

Reporter, could you install the latest nightly build and try it again?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
Keywords: crash, stackwanted

Comment 2

16 years ago
WFM too, using 1.1 RC build from 18/08/2002.
(Reporter)

Comment 3

16 years ago
Ok, works for me with todays nightly build (2002082208) some way. At least
mozilla doesn't crash anymore but the result looks not as it should. I'll create
two attachments: 
1. screenshot from IE6 --> correct display
2. screenshot from mozilla --> broken display
(Reporter)

Comment 4

16 years ago
Created attachment 96432 [details]
Screenshot from IE6 --> correct display
(Reporter)

Comment 5

16 years ago
Created attachment 96433 [details]
Screenshot from Mozilla --> broken display
By adding "fieldset { padding: 0; }" to the style section in the HEAD, a better
rendering is achieved in Mozilla (http://www.hut.fi/u/tsknorri/test/2.html). So
I think that the display difference is caused by Mozilla and IE having different
defualt values for CSS properties. By default Mozilla has a fieldset padding of
X (whatever it is), as IE seems to have it set to zero. So for the layout to
work you have to explicitly specify the fieldset padding in order to prevent
browsers from using their implicit default values.

So Mozilla's layout isn't "broken", it is just by defualt not the same as that
of IE.

I'm sure that by further tweaking the CSS properties you can achieve the same
(or at least a sufficiently same) rendering in all leading browsers.

Comment 7

16 years ago
Please DO NOT combine two or more bug reports in one bug!!!

Your crash report is a dup of bug 130251 (has just been fixed). To report the
padding problem, please file a separate bug.

*** This bug has been marked as a duplicate of 130251 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Summary: Mozilla crashes while trying to open http://www.blechdachs.de/test.html → Mozilla crashes while trying to open http://www.blechdachs.de/test.html [fieldset with position:absolute]

Updated

16 years ago
Keywords: stackwanted
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.