Closed Bug 1642436 Opened 6 months ago Closed 6 months ago

Update collection dismiss pref default

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 79
Iteration:
79.1 - June 1 - June 14
Tracking Status
firefox78 - fixed
firefox79 --- verified

People

(Reporter: thecount, Assigned: thecount)

References

Details

Attachments

(1 file)

We want to update the default value of browser.newtabpage.activity-stream.discoverystream.isCollectionDismissible from false to true.

To Test:

  1. Set browser.newtabpage.activity-stream.discoverystream.endpoints to http,https
  2. Set browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":false,"personalized":true,"layout_endpoint":"https://e5e8374d-fffa-4a77-a604-31603852b6fd.mock.pstmn.io/collectiontest"}

Expected, you should see a collection in the top row of newtab with a dismiss button.

If you're outside the US, you also need to set this pref: browser.newtabpage.activity-stream.discoverystream.spocs-endpoint to https://spocs.getpocket.com/spocs?site=1123212&region=CA&country=US

This pref is read here: https://searchfox.org/mozilla-central/source/browser/components/newtab/common/Reducers.jsm#789

This sets some state, which in turn sets this inside a react component: browser

Assignee: nobody → sdowne
Status: NEW → ASSIGNED

To test with more than three items, for now, use these steps:

  1. Set browser.search.region to US.
  2. Set browser.newtabpage.activity-stream.discoverystream.endpoints to http,https.
  3. Set browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":false,"personalized":true,"layout_endpoint":"https://e5e8374d-fffa-4a77-a604-31603852b6fd.mock.pstmn.io/1615081-layout"}
Pushed by sdowne@getpocket.com:
https://hg.mozilla.org/integration/autoland/rev/c3b6e1ef06b4
Update default pref for collection dismiss r=Mardak
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

This issue was part of the work done for [PI-643] Staged Rollout: activity-stream story collection dismiss pref that was signed off as GREEN. Considering this I am marking this issue as VERIFIED.

Status: RESOLVED → VERIFIED

[Tracking Requested - why for this release]: We're good flipping this on in beta too. This means the flip hits release sooner.

Right now there is a rollout for this value to flip, we're confident in it and are moving it to true for all channels.

Comment on attachment 9153210 [details]
Bug 1642436 - Update default pref for collection dismiss

Beta/Release Uplift Approval Request

  • User impact if declined: User experience for collections impacted by not being able to be dismissed.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: To Test:
  1. Set browser.newtabpage.activity-stream.discoverystream.endpoints to http,https
  2. Set browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":false,"personalized":true,"layout_endpoint":"https://e5e8374d-fffa-4a77-a604-31603852b6fd.mock.pstmn.io/collectiontest"}

Expected, you should see a collection in the top row of newtab with a dismiss button.

If you're outside the US, you also need to set this pref: browser.newtabpage.activity-stream.discoverystream.spocs-endpoint to https://spocs.getpocket.com/spocs?site=1123212&region=CA&country=US

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's a 1 line pref flip for a pref that's been tested with a normandy study previously, and is currently on via rollout in release.
  • String changes made/needed: none
Attachment #9153210 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I don't think I need to track this.

See Also: → 1642682

The rollout in bug 1642682 seems to be limited to en-US builds. What's the effect for this on localized builds, whether inside or outside the US?

Flags: needinfo?(sdowne)
Iteration: --- → 79.1 - June 1 - June 14
Priority: -- → P1

This pref is fine to be on globally.

It augments an existing feature (collections) that, has separate controls on a per locale basis. (the value in the content and if spocs are enabled)

Spocs are currently enabled in US only right now, and the collections content is only available for US too. If either of those two are false, this pref is ignored.

When we enable collections for other regions or locales, we would want the value in this pref to be the same for all locales, for the foreseeable future.

Flags: needinfo?(sdowne)

Comment on attachment 9153210 [details]
Bug 1642436 - Update default pref for collection dismiss

approved for 78.0b5

Attachment #9153210 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.