Closed Bug 1642506 Opened 8 months ago Closed 5 months ago

Perma [Ccov] [tier2]/html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | <script> error: Move fetch-error external classic script to createHTMLDocument

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- fixed
firefox80 --- wontfix
firefox81 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: aryx)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=304599359&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/ITIAwql6QgeRhw3t5U346g/runs/0/artifacts/public/logs/live_backing.log


[task 2020-06-01T21:09:57.546Z] 21:09:57 INFO - TEST-START | /html/the-xhtml-syntax/parsing-xhtml-documents/xhtml-mathml-dtd-entity-1.htm
[task 2020-06-01T21:10:01.029Z] 21:10:01 INFO -
[task 2020-06-01T21:10:01.029Z] 21:10:01 INFO - TEST-PASS | /html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | Sanity check around top-level Window
[task 2020-06-01T21:10:01.029Z] 21:10:01 INFO - TEST-PASS | /html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | Eval: Move fetch-error external classic script to createHTMLDocument after-prepare
[task 2020-06-01T21:10:01.030Z] 21:10:01 INFO - TEST-PASS | /html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | <script> load: Move fetch-error external classic script to createHTMLDocument after-prepare
[task 2020-06-01T21:10:01.030Z] 21:10:01 INFO - TEST-UNEXPECTED-FAIL | /html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | <script> error: Move fetch-error external classic script to createHTMLDocument after-prepare - assert_unreached: Event fired unexpectedly Reached unreachable code
[task 2020-06-01T21:10:01.030Z] 21:10:01 INFO - scriptOnError@http://web-platform.test:8000/html/semantics/scripting-1/the-script-element/moving-between-documents/resources/moving-between-documents-helper.js:121:65
[task 2020-06-01T21:10:01.030Z] 21:10:01 INFO - onerror@http://web-platform.test:8000/html/semantics/scripting-1/the-script-element/moving-between-documents/resources/moving-between-documents-iframe.py?result=fetch-error&inlineOrExternal=external&type=classic&hasBlockingStylesheet=true&cache=0.8115254958264662:1:14
[task 2020-06-01T21:10:01.030Z] 21:10:01 INFO - .
[task 2020-06-01T21:10:01.030Z] 21:10:01 INFO - TEST-OK | /html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | took 12529ms
[task 2020-06-01T21:10:01.060Z] 21:10:01 INFO - PID 3028 | 1591045801057 Marionette INFO Stopped listening on port 50814
[task 2020-06-01T21:10:01.421Z] 21:10:01 INFO - PID 3028 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-01T21:10:01.837Z] 21:10:01 INFO - PID 3028 | ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-01T21:10:11.687Z] 21:10:11 INFO -
[task 2020-06-01T21:10:11.687Z] 21:10:11 INFO - TEST-OK | /html/the-xhtml-syntax/parsing-xhtml-documents/xhtml-mathml-dtd-entity-1.htm | took 14139ms

James, please take a look.

Flags: needinfo?(james)
Regressed by: 1642094
Summary: Perma [Win Ccov] [tier2]/html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | <script> error: Move fetch-error external classic script to createHTMLDocument → Perma [Ccov] [tier2]/html/semantics/scripting-1/the-script-element/moving-between-documents/after-prepare-createHTMLDocument-fetch-error-external-classic.html | <script> error: Move fetch-error external classic script to createHTMLDocument

Looks like the wptsync fixed this.

Flags: needinfo?(james)
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WORKSFORME

This is happening again due to https://hg.mozilla.org/mozilla-central/rev/a46f26c160a5.
I'm reopening the bug.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Regressed by: 1656228
Assignee: nobody → aryx.bugmail
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/a2312f2a7a80
adjust Windows ccov expectations in html/semantics/scripting-1/the-script-element/moving-between-documents/*. r=intermittent-reviewers,jmaher DONTBUILD
Status: REOPENED → RESOLVED
Closed: 8 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

Change the status for beta to have the same as nightly and release.
For more information, please visit auto_nag documentation.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 81 Branch → ---

So we need this?

if (os == "win") and ccov: FAIL
if not debug and (os == "win"): PASS
FAIL
Flags: needinfo?(james)

Made a patch.

Flags: needinfo?(james)
Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/9af64090b5d4
Add back Windows ccov test annotations for moving-between-documents folder

Latest check-in is supposed to fix it.

Flags: needinfo?(aryx.bugmail)
You need to log in before you can comment on or make changes to this bug.