Closed Bug 1642599 Opened 10 months ago Closed 25 days ago

Enable console message listening from the server side for process and worker targets

Categories

(DevTools :: Console, enhancement)

enhancement

Tracking

(Fission Milestone:M7, firefox87 disabled, firefox88 fixed)

RESOLVED FIXED
88 Branch
Fission Milestone M7
Tracking Status
firefox87 --- disabled
firefox88 --- fixed

People

(Reporter: ochameau, Assigned: nchevobbe)

References

(Blocks 3 open bugs)

Details

(Whiteboard: dt-fission-m3-mvp)

Attachments

(5 files)

Bug 1620243 introduced the implementation to listen for console messages via the Watcher Actor, but only for Tab targets. It will be disabled in that bug. Bug 1642295 is going to enable this, but still only for tab targets.
We should also enable it for processes and workers.
But, to do that, we would need to have the Watcher Actor to handle process and worker targets. i.e. bug 1620248 and bug 1633712.

Tracking dt-fission-m2-mvp bugs for Fission Nightly milestone (M6c).

Fission Milestone: --- → M6
Fission Milestone: M6 → M6c
Whiteboard: dt-fission-m2-mvp → dt-fission-m3-mvp

Bulk move of all dt-fission-m3-mvp bugs to Fission MVP milestone.

Fission Milestone: M6c → MVP

Let's see what try says:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=90c363c4da62ee660c31c4521d208a407602e8c5

It isn't clear what could go wrong here. It sounds like it should "just work".
ConsoleMessageWatcher already contains worker-specific codepaths and I think there is also conditions and lines specific to processes.

The ultimate goal here is to have the same codepaths between all tooboxes. As, for now, we are still using legacy listeners for the browser toolboxes and most of the toolboxes spawn from about:debugging (WebExtension, workers).
We may still need some additonal work to support Watchers for WebExtension and workers (bug 1675763).

Once this is done, we can remove the old codepath, i.e. startListeners(["ConsoleAPI"]):
https://searchfox.org/mozilla-central/rev/dac45cc7020dfddbcc937827810dd11550c07dc3/devtools/server/actors/webconsole.js#636-647

Blocks: 1687459

Moving some dt-fission-m3-mvp bugs from Fission MVP to M7 (blocking Beta experiment).

Fission Milestone: MVP → M7
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Blocks: 1605036
Depends on: 1689297
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/78c0f05f8978
[devtools] Enable all console messages server support everywhere. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
Regressions: 1692476
Regressions: 1692838
Regressions: 1693854

Reopening as this was reverted in Bug 1693854

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED

Backed out from Beta87 also.

Target Milestone: 87 Branch → ---
Depends on: 1696856
No longer blocks: 1696862

The patch for Bug 1697453 made it so we weren't dispatching resources tied to
a target being destroyed. This revealed an issue when adding a test for webextension
popup messages, where the target is being destroyed before the browser console can
consume it (see following patches in this queue).
Since Bug 1697453 was only done to try to make browser_toolbox_backward_forward_navigation.js
pass when fission is enabled, and given it's still failing, let's revert this
patch for now and reassess if this is needed, and if so, if we shoul only do that
for some specific resources.

Depends on D107648

We're getting those messages directly from the frame targets, so we can safely
ignore them in the content process.
A test case is added in a following patch in this queue.

Depends on D108394

Blocks: 1699050
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6dd3d456f592
[devtools] Don't use watchers in browser console/toolbox if devtools.browsertoolbox.fission is disabled. r=ochameau.
https://hg.mozilla.org/integration/autoland/rev/2ffd7b7ad755
[devtools] Revert Bug 1697453. r=ochameau.
https://hg.mozilla.org/integration/autoland/rev/1402d84905c1
[devtools] Add test for webextension messages in Browser Console. r=ochameau.
https://hg.mozilla.org/integration/autoland/rev/cba0fce56522
[devtools] Don't handle CSS messages in content processes. r=ochameau.
https://hg.mozilla.org/integration/autoland/rev/82176cf8ae49
[devtools] Enable all console messages server support everywhere. r=ochameau,devtools-backward-compat-reviewers.
Regressions: 1699117
You need to log in before you can comment on or make changes to this bug.