Closed Bug 1642707 Opened 4 months ago Closed 3 months ago

Firefox no longer sends VoiceOver a notification that the page finished loading.

Categories

(Core :: Disability Access APIs, defect, P1)

79 Branch
All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- wontfix
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- verified

People

(Reporter: MarcoZ, Assigned: morgan)

References

(Regressed 1 open bug)

Details

(Keywords: regression, Whiteboard: [mac2020_1])

Attachments

(1 file)

This was implemented by Hub Figuiere in 2012 or 2013, but got broken some time ago, probably in E10S.

STR:

  1. In Safari, load any web site with VoiceOver on.
    • Result: When the page finishes loading, VoiceOver emits three ascending tones that indicate that it is ready to read the page.
  2. Do the same in Firefox.
    • Expected: We'd hear the same ascending tones.
    • Actual: No tones are being played.

I think this was broken even before Eitan's refactor in Bug 1624729. It was fired on the native accessible element. According to Chromium source, "AXLoadComplete" should only be fired on the root element, and "AXLayoutComplete" on iframes. We're firing all in both cases, and that might be wrong nowadays. Chromium changed that some time in 2015 or so.
NI'ing Eitan since we just talked about this on Zoom.

Flags: needinfo?(eitan)
Assignee: nobody → eitan
Flags: needinfo?(eitan)
Assignee: eitan → mreschenberg
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b03bb10f9e2e
Add web area class and attributes r=eeejay
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Regressions: 1648813

Confirmed lack of notification with 77.0b7.
Fix verified with 79.0b2 on macOS 10.5.5.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.