Closed Bug 1642810 Opened 2 years ago Closed 2 years ago

Global Sharing Overlay can't be brought up after being closed

Categories

(Firefox :: Site Permissions, defect, P1)

Desktop
Unspecified
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox79 --- wontfix

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Preconditions

  • Flip privacy.webrtc.allowSilencingNotifications to true
  • Flip privacy.webrtc.legacyGlobalIndicator to false

Affected versions

  • 77.0b9
  • 78.0a1 (2020-05-22)

Affected platforms

  • Windows 10

Steps to reproduce

  1. Launch Firefox and access: https://whereby.com/
  2. Start a video call.
  3. Hover over the Firefox icon in the taskbar.
  4. Close the window with the Global Sharing Overlay.

Expected result

  • The Global Sharing Overlay shouldn't be closable or there should be a way for it to be brought back up.

Actual result

  • The bar is closed and you can't make it appear again on the same call.

Regression range

  • It's a feature implementation bug.

From dbodea:

This new Global Sharing Indicator cannot be closed on MacOS and this seems to be a correct approach; It can be minimized in the dock, but not closed. Furthermore, the old Global Sharing Indicator can't be closed on Windows either, it can just be dragged on the top of the main screen.

It appears that this issue is also reproducing on Ubuntu 18.04.4LTS.

So this is an issue that occurs on both Windows and Linux OSes, but not on MacOS.
This might need a UX opinion, but the impossibility of closing the Global Sharing Overlay might be the best approach. It is how it was previously designed.

S1 or S2 bugs need an assignee - could you find someone for this bug?

Flags: needinfo?(pbz)
Assignee: nobody → mconley
Flags: needinfo?(pbz)

I'm been looking into this.

This might need a UX opinion, but the impossibility of closing the Global Sharing Overlay might be the best approach. It is how it was previously designed.

There's a trade-off here. The old type of window wasn't closeable, but also wasn't minimizable. If we want the indicator to be minimizable and restorable, and it needs to appear in the Windows Task bar. If it appears in the Windows Task bar, then the window is close-able.

So our choices here are:

  1. Don't make the indicator minimizable
  2. Handle the closing of the indicator - either by re-opening the indicator, or perhaps by terminating all share streams.

Hey aaron, given comment 2... which direction do you think we should head?

Flags: needinfo?(abenson)

I don't think it's a problem if people close the indicator as there are other ways to be able to get back to the share functions (e.g. from the control panel in the URL bar). I don't know if closing it is necessarily a strong enough signal they want to end the screen share either. They may just want that bit of UI out of the way.

Flags: needinfo?(abenson)

Alrighty - so it sounds like this is a WONTFIX. Thanks, aaron!

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
See Also: → 1672432
You need to log in before you can comment on or make changes to this bug.