Table cell background image behind foreground transparent image not printed

RESOLVED DUPLICATE of bug 141656

Status

()

Core
Printing: Output
P2
normal
RESOLVED DUPLICATE of bug 141656
16 years ago
15 years ago

People

(Reporter: Peter Niemayer, Assigned: dcone (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If you have a table cell that contains a (more or less) transparent image, and
there's a background image behind that, Mozilla does not even try to render that
background image on the nsRenderingContext* used for printing - the
nsRenderingContext::DrawImage() function is only called for the foreground
image. And yes, "print background" was enabled :-)

Sample HTML code (you can of course replace the image links):

<html>
<body>
<table cellpadding="0" cellspacing="0" border="0">
 <tr>
  <td style="background-image:url(http://www.lycos.de/L/G/N/stau2.jpg)">
   <img src="http://www.lycos.de/L/Z/grahm.gif" alt="" border="0" >
  </td>
 </tr>
</table>
</body>
</html>

This I think is especially strange as the background image is displayed in the
print preview...
(Reporter)

Comment 1

16 years ago
Maybe I should additionally mention that this bug cannot be noticed when using
the ordinary nsRenderingContextPS, as that one doesn't support transparent
images correctly at all.

But any sane nsRenderingContext* used for printing suffers :-)

Comment 2

16 years ago
Confirming this behaviour on Build ID 2002-08-23.

For clarification:
Steps to reproduce:
1. Open the attached testcase in a browser window
2. Select "File" | "Print Preview"
3. Note that an empty box is displayed
4. Open the "Page Setup" dialog and check "Print background ..."
5. Note that the picture is now displayed in what was a white box
6. Print and note that the results are the same as step 3

Expected Result:
The background image is printed with the foreground

Actual Result:
Only the foreground image is printed
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Created attachment 96471 [details]
Testcase described in comment 2

Comment 4

16 years ago
->
Assignee: rods → dcone
(Assignee)

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 141656 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.