Closed Bug 1643035 Opened 1 year ago Closed 11 months ago

Ensure the new WebRTC global sharing indicator with notification silencing meets our accessibility standards.

Categories

(Firefox :: Site Permissions, task, P1)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: mconley, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [access-s2])

From Asa:

I've made a quick pass over the new UIs and for the most part things work. There are some exceptions. (I tested on Windows 10 with today's Nightly)

There are no focus rectangles on the sharing, mic and camera buttons in the sharing indicator window. The minimize button does have a focus indicator but not the other three buttons.

The "You are sharing [Window name]" in the sharing indicator window which is visually displayed isn't read by the screen reader, just the "stop sharing" button.

I'll continue testing but wanted to get you this feedback early.

From jteh:

I have some major concerns here:

A screen reader user isn't made aware of this indicator at all. We could probably use role="alert" on the window so users are notified when it appears.

Keyboard only users (including screen reader users) can't get to the window or its controls. Asa said he was able to alt+tab to it a few days ago, but that is no longer possible. Perhaps this is related to bug 1641495, which mentions the taskbar icon not being available when the indicator is minimised? For me, the taskbar icon is never available at all, hence no alt+tab.

If we don't want alt+tab to get to it, my first thought is that ideally, f6 would focus it like it focuses all other notifications. Unfortunately, that's tricky (maybe impossible) because this is a global window. The problem is that if we use some other keyboard command, this isn't going to be discoverable.

Like the legacy indicator, this is triggering bug 1427304, which causes freezes/delays in screen readers. I need help from Windows widget folks to figure that out; there's a 1 year old NI without a response. :(

I'm not sure if this is part of the redesign or not, but the permission doorhanger for screen sharing includes a video with id webRTC-previewVideo which ends up in the tab order as an unlabelled grouping. I guess this is just focusable because videos are normally focusable? I don't think it serves any purpose, though, because as I understand it, you can't interact with that video in any way. Can we take this out of the tab order (tabindex="-1"?) or at least give it aria-label="Screen sharing preview" or something?

(In reply to Mike Conley (:mconley) (:⚙️) (Extremely busy) from comment #0)

From Asa:

The "You are sharing [Window name]" in the sharing indicator window which is visually displayed isn't read by the screen reader, just the "stop sharing" button.

To this, jteh responds with:

That could be solved by giving div#display-share these attributes: role="group" aria-labelledby="window-share-info". Screen readers read group ancestors when a control gets focus.

(In reply to Mike Conley (:mconley) (:⚙️) (Extremely busy) from comment #0)

A screen reader user isn't made aware of this indicator at all. We could probably use role="alert" on the window so users are notified when it appears.

Done in bug 1642260.

Keyboard only users (including screen reader users) can't get to the window or its controls.

We don't have a separate bug for this yet.

Like the legacy indicator, this is triggering bug 1427304, which causes freezes/delays in screen readers.

Fixed in that bug.

I'm not sure if this is part of the redesign or not, but the permission doorhanger for screen sharing includes a video with id webRTC-previewVideo which ends up in the tab order as an unlabelled grouping.

We don't have a separate bug for this yet.

Depends on: 1643545
Depends on: 1643546

Keyboard only users (including screen reader users) can't get to the window or its controls.

Filed as bug 1643545.

I'm not sure if this is part of the redesign or not, but the permission doorhanger for screen sharing includes a video with id webRTC-previewVideo which ends up in the tab order as an unlabelled grouping.

Filed as bug 1643546.

Depends on: 1644904
Depends on: 1644905
Depends on: 1643012

Hey Asa, jteh and I have closed a number of accessibility issues on the new indicator since this bug was filed. The only one remaining that I'm tracking here is regarding high-contrast mode. Are you aware of any other accessibility issues with the new indicator?

Flags: needinfo?(asa)
Depends on: 1646958

There are no more blocking bugs on this metabug, and I haven't heard from Asa nor jteh about new accessibility issues with the indicator, so I'm going to mark this as RESOLVED FIXED.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Flags: needinfo?(asa)
You need to log in before you can comment on or make changes to this bug.