Closed Bug 1643200 Opened 29 days ago Closed 27 days ago

klsihk64.dll still causes crash because BLOCK_WIN8_ONLY is not working

Categories

(Firefox :: Launcher Process, defect, P3)

Unspecified
Windows 8
defect

Tracking

()

RESOLVED FIXED
Firefox 79
Tracking Status
firefox-esr68 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- fixed
firefox79 --- fixed

People

(Reporter: toshi, Assigned: toshi)

References

(Regression)

Details

(Keywords: regression)

Crash Data

Attachments

(1 file)

Because a new blocklist (bug 1445025) compares OS version incorrectly, the flag BLOCK_WIN8_ONLY does not block anything. As a result, crashes in klsihk64.dll (bug 1268470) reappears.

Crash Signature: klsihk64.dll | mozglue.dll | js::gc::GCRuntime::GCRuntime klsihk64.dll klsihk64.dll | js::gc::GCRuntime::GCRuntime → klsihk64.dll | mozglue.dll | js::gc::GCRuntime::GCRuntime klsihk64.dll

BLOCK_WIN8_ONLY was introduced by bug 1268470 to block klsihk64.dll only on
Win8. However, a new blocklist (bug 1445025) does wrong comparison on the OS
version, thus BLOCK_WIN8_ONLY has blocked modules on all platforms older than
Win10 including Win7 and Win8.1.

This patch corrects OS comparison and changes the flag to BLOCK_WIN8_AND_OLDER
to make it more handy. We also remove BLOCK_WIN8PLUS_ONLY which is never used.

Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0925727e395c
Rename BLOCK_WIN8_ONLY into BLOCK_WIN8_AND_OLDER. r=mhowell
Status: NEW → RESOLVED
Closed: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

The patch landed in nightly and beta is affected.
:toshi, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(tkikuchi)
Duplicate of this bug: 1553397
Crash Signature: klsihk64.dll | mozglue.dll | js::gc::GCRuntime::GCRuntime klsihk64.dll → klsihk64.dll | mozglue.dll | js::gc::GCRuntime::GCRuntime klsihk64.dll [@ klsihk64.dll | js::gc::GCRuntime::GCRuntime] [@ klsihk64.dll | js::wasm::EnsureEagerProcessSignalHandlers]

Comment on attachment 9154398 [details]
Bug 1643200 - Rename BLOCK_WIN8_ONLY into BLOCK_WIN8_AND_OLDER. r=mhowell

Beta/Release Uplift Approval Request

  • User impact if declined: Firefox may crash on Windows 8 if an old version of Kaspersky is installed. This is a long-standing regression. We had blocked it in version 57 (bug 1268470), but it has not been blocked since version 62 (bug 1445025).
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is a minor update of the comparison logic of OS version. We used to compare it to "8.0", but we need to do with "6.2" because it's a kernel version.
  • String changes made/needed: None
Flags: needinfo?(tkikuchi)
Attachment #9154398 - Flags: approval-mozilla-beta?

Comment on attachment 9154398 [details]
Bug 1643200 - Rename BLOCK_WIN8_ONLY into BLOCK_WIN8_AND_OLDER. r=mhowell

approved for 78.0b7

Attachment #9154398 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.