Closed Bug 1643219 Opened 2 years ago Closed 1 year ago

[Wayland] (Re-)plugging a monitor on GNOME 3.36 results in artifacts on Alt-Tab or Overview

Categories

(Core :: Graphics, defect, P3)

79 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: intelfx, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:79.0) Gecko/20100101 Firefox/79.0

Steps to reproduce:

  • Use GNOME 3.36 / Wayland
  • get a laptop w/ Intel integrated graphics (tested on X1 Carbon 6th) and an external HiDPI (4K) display
  • close the laptop lid and connect it to an external display, OR
  • keeping the laptop lid closed, unplug and replug an external display

Or in prose: under GNOME 3.36 / Wayland, connecting my laptop (X1 Carbon 6th) to an external display after closing the laptop lid, or re-plugging the external display while the laptop lid is closed, causes visual artifacts to appear every time I Alt-Tab into a Firefox window or enter/exit the Overview.

Actual results:

Visual artifacts and flickering occurs every time I enter or exit Overview or Alt-Tab into a Firefox window:

Sometimes, major artifacts occur in Overview (that is, rapid flickering outside of the Firefox window preview), but I was unable to capture any occurrence of these.

Expected results:

No visual artifacts (compare):

https://intelfx.name/files/persistent/2020-06-04%20firefox%20artifacts/normal.webm

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Graphics
Product: Firefox → Core
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Blocks: wayland
Severity: -- → S3

Looks like Firefox gets confused about different buffer scales. Do your monitors (the internal one and the external one) have different scales set in the Gnome display settings? Could you check if the same reproduces if both are set to 100%?

Flags: needinfo?(intelfx)

(In reply to Robert Mader [:rmader] from comment #2)

Looks like Firefox gets confused about different buffer scales. Do your monitors (the internal one and the external one) have different scales set in the Gnome display settings? Could you check if the same reproduces if both are set to 100%?

Both monitors are 200%, and the bug indeed does not manifest itself when both are configured to 100%.

But I think I can shed some more light on the problem. After I replug the external monitor, all Wayland windows start to exhibit slightly problematic behavior (but less pronounced than Firefox). Specifically, upon entering Overview, the window content gets blurred, as if the window renders at 100% and is then upscaled to 200%. Observe:

So I'd say there are two bugs, one somewhere on GNOME side and one in Firefox, and the former exacerbates the latter.

Flags: needinfo?(intelfx)

https://intelfx.name/files/persistent/2020-06-05%20gnome-terminal%20artifacts/after.webm

Wow, even the mouse cursor switches between scales. This looks very much like a bug in GS - maybe FF also has bugs, maybe it just shows stronger symptoms. Mind creating an issue at https://gitlab.gnome.org/GNOME/mutter/-/merge_requests ?

Ah and before you do, could you test if the same happens with the experimental/fractional GS scaling? It generally works more reliable - would already help to know for debugging (gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']")

(In reply to Robert Mader [:rmader] from comment #4)

https://intelfx.name/files/persistent/2020-06-05%20gnome-terminal%20artifacts/after.webm

Wow, even the mouse cursor switches between scales. This looks very much like a bug in GS - maybe FF also has bugs, maybe it just shows stronger symptoms. Mind creating an issue at https://gitlab.gnome.org/GNOME/mutter/-/merge_requests ?

Ah and before you do, could you test if the same happens with the experimental/fractional GS scaling? It generally works more reliable - would already help to know for debugging (gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']")

Done: https://gitlab.gnome.org/GNOME/mutter/-/issues/1286

For the record, gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" does not appear to help.

More severe visual artifacts that happen occasionally within described situation:

(I apologize for a camera capture — those artifacts disappear when screencasting)

Robert, I think this is mutter bug, right?
Thanks.

Flags: needinfo?(robert.mader)
Priority: -- → P3

Most likely, yes.

Flags: needinfo?(robert.mader)

Ivan, do you still see it? Looks like an issue with mutter subsurface. I can't reproduce it. Please try latest mutter version available and reopen if you still see it.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Yes, the bug does not appear anymore since a few months ago.

You need to log in before you can comment on or make changes to this bug.