Closed Bug 1643293 Opened 1 year ago Closed 1 year ago

Make a documentation renderer at review phase

Categories

(Firefox Build System :: Documentation Infrastructure, enhancement, P3)

enhancement

Tracking

(firefox80 fixed)

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: gilatank, Assigned: gilatank)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36

It would be great if we have a documentation renderer at review phase. It will make the reviewing process faster since reviewer doesn't have to pull the changes and build the documentation locally. They could just see the changes to the documentation on s3.

We could make a new job that builds the documentation whenever there is changes to doc files (.md and .rst) and upload it directly to s3.
https://searchfox.org/mozilla-central/source/tools/moztreedocs/mach_commands.py

Priority: -- → P3

Fyi it's possible to view the results of a DocUp build on try by visiting this link:
http://gecko-docs.mozilla.org-l1.s3-website.us-west-2.amazonaws.com/

So if reviewbot were to run the DocUp task, it could post the link as a comment. The main issue is that try pushes will overwrite one another, so we'd need to modify the DocUp task to upload files to a namespace keyed by the push revision (and set an expiry of a week or so). Shouldn't be too hard to do.

(In reply to Andrew Halberstadt [:ahal] from comment #2)

Fyi it's possible to view the results of a DocUp build on try by visiting this link:
http://gecko-docs.mozilla.org-l1.s3-website.us-west-2.amazonaws.com/

So if reviewbot were to run the DocUp task, it could post the link as a comment. The main issue is that try pushes will overwrite one another, so we'd need to modify the DocUp task to upload files to a namespace keyed by the push revision (and set an expiry of a week or so). Shouldn't be too hard to do.

i cant seem to access the link.

probably because nothing has been uploaded recently.
You could use "try" with docup to try this :)

Assignee: nobody → gilatank
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a788bf738a87
added new job in doc to render documentation at review phase r=sylvestre,ahal
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Regressions: 1651606
Regressions: 1652286
Regressions: 1664764
Depends on: 1664771
Depends on: 1679406
Depends on: 1679420
You need to log in before you can comment on or make changes to this bug.