Closed Bug 1643495 Opened 2 years ago Closed 2 years ago

Permafailing tier 2 TEST-UNEXPECTED-TIMEOUT | editor/libeditor/tests/test_bug569988.html | application timed out after 370 seconds with no output

Categories

(Core :: DOM: Editor, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: saschanaz)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell unknown])

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=305111691&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/PnlGpIC7Tr6jiofZNxq5pQ/runs/1/artifacts/public/logs/live_backing.log


[task 2020-06-04T20:06:58.519Z] 20:06:58 INFO - TEST-START | editor/libeditor/tests/test_bug569988.html
[task 2020-06-04T20:13:08.570Z] 20:13:08 INFO - Buffered messages logged at 20:06:58
[task 2020-06-04T20:13:08.570Z] 20:13:08 INFO - must wait for load
[task 2020-06-04T20:13:08.571Z] 20:13:08 INFO - opening prompt...
[task 2020-06-04T20:13:08.572Z] 20:13:08 INFO - TEST-PASS | editor/libeditor/tests/test_bug569988.html | onPromptLoad is called
[task 2020-06-04T20:13:08.572Z] 20:13:08 INFO - TEST-PASS | editor/libeditor/tests/test_bug569988.html | onPromptFocus is called
[task 2020-06-04T20:13:08.573Z] 20:13:08 INFO - sending key
[task 2020-06-04T20:13:08.574Z] 20:13:08 INFO - Buffered messages finished
[task 2020-06-04T20:13:08.575Z] 20:13:08 ERROR - TEST-UNEXPECTED-TIMEOUT | editor/libeditor/tests/test_bug569988.html | application timed out after 370 seconds with no output
[task 2020-06-04T20:13:08.575Z] 20:13:08 ERROR - Force-terminating active process(es).

Regressed by: 1632425
Flags: needinfo?(krosylight)

Not sure how this is related to the mousedown patch as the test never fires any mouse event. Masayuki, do you have an idea? Seemingly only Linux is affected, interesting.

Flags: needinfo?(krosylight) → needinfo?(masayuki)

Set release status flags based on info from the regressing bug 1632425

Yeah, it's really odd if bug 1632425 caused this. But looks like that this is not a permanent failure. So, perhaps, other landing may have already caused this.

Flags: needinfo?(masayuki)

I highly doubt Bug 1632425 has anything to do with this failure, so we first need to check what causes it.

Flags: needinfo?(krosylight)

The backfills shows this permanent failure starts with the landing of bug 1632425. The green retriggers of the h3 task are caused by bug 1585757 (build from previous push used).

Bug 1632425 modified editor/libeditor/tests/test_bug417418.html which gets executed earlier in the task and disabling it let's it pass on Try. Maybe Masayuki has an idea what changed.

Thanks :aryx! In that case the simplest solution would be reverting the specific file change as I don't need it anymore. (Only the previous version of the patch needed it.)

My guess is that the test for 417418 opens a context menu without closing it when it ends, and that conflicts with the prompt test as the Escape key will close the menu instead of the prompt.

Flags: needinfo?(masayuki)

This change was only needed when the previous version of the patch for Bug 1632425 wanted to move things into contextmenu event handler. This patch reverts the change as 1) the suggested behavior never landed and 2) opening context menu in a test can cause conflict with other tests.

Assignee: nobody → krosylight
Status: NEW → ASSIGNED
Pushed by krosylight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cb257144ee3a
Revert contextmenu change in test_bug417418 r=masayuki
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.