Closed Bug 1643626 Opened 2 years ago Closed 2 years ago

Yellow arrows when searching for firefox string in about:preferences on Firefox will remember history drop-down

Categories

(Firefox :: Preferences, defect)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- wontfix

People

(Reporter: atrif, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image firefox_arrow.gif

Affected versions

  • 77.0.1 (20200602222727)
  • 78.0b3 (20200604213430)
  • 79.0a1 (20200604220012)

Affected platforms

  • macOS 10.15
  • Windows 10x64
  • Windows 8.1x64
  • Ubuntu 18.04

Steps to reproduce

  1. Open Firefox and about:preferences.
  2. Search for firefox string and scroll down to History drop-down.
  3. Click on the Firefox will Remember history drop down.

Expected result

  • The dropdown items have no yellow arrows.

Actual result

  • Yellow arrows are shown in the dropdown menu.

Regression range
Last good revision: 85b2d74f745170e2826d1dddd26e16cbf22ffe87
First bad revision: 43d5a2bbdd3696302094a8fee45a35282e562586
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=85b2d74f745170e2826d1dddd26e16cbf22ffe87&tochange=43d5a2bbdd3696302094a8fee45a35282e562586

Notes

  • Attached a screen recording with the issue.
Has Regression Range: --- → yes
Has STR: --- → yes

This is because the menuitems have search-l10n-ids that point to the descriptions and labels for controls that appear underneath the dropdown when you select some of the items.

I don't know that we can do anything about this, so we might just wontfix it. It's maybe a little confusing, but it's necessary in order to be able to identify the dropdown as showing/hiding the other content that it controls, which contains other words like "form" or "download" that may not find the entry otherwise. Maybe there's a way we could make it more obvious why these items match, but I don't really know how we'd do that. Jared, thoughts?

Flags: needinfo?(jaws)

We could maybe do something if the arrow is present on all menuitems but I think that would be engineering a solution to a problem that is likely not a big deal for users. Searching for "firefox" in the Firefox preferences is a bit of a convoluted testcase. The solution we implemented is more useful for searching for something like "clear history" which will only place an arrow on the Custom option in this case.

With that being said, I'm going to close this bug as wontfix.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jaws)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.