Closed Bug 1643863 Opened 4 months ago Closed 3 months ago

[merge scripts] Beta l10n repacks use "nightly" branding

Categories

(Thunderbird :: Build Config, defect, P1)

Tracking

(thunderbird78 fixed)

RESOLVED FIXED
Thunderbird 78.0
Tracking Status
thunderbird78 --- fixed

People

(Reporter: rjl, Assigned: rjl)

References

(Regression)

Details

Attachments

(2 files, 1 obsolete file)

MacOS l10n repacks failing on 78.0beta1

I made some changes in Bug 1619767 to mail/config/mozconfigs/l10n-common in anticipation of automated merge day activities happening. However we have continued to use the existing merge scripts, which do not take the change into account.

https://hg.mozilla.org/comm-central/rev/029fd20ab19e

There will be two parts to the fix.
First, that branding line needs to be removed from the copy of this file in comm-beta. As that should have been done by merge day activities, there will be no corresponding comm-central change.

Second, a change needs to be made to the merge scripts, or make sure we switch to automation before next merge day. I propose planning for both.

I believe that change is also the cause of bug 1637349.

https://hg.mozilla.org/releases/comm-beta/file/a352facfa0a4cb116e8d407183c995d908498b2a/mail/config/mozconfigs/l10n-common

That's what this file should look like on comm-beta. The only change to make is to remove the "branding/nightly" line.

Assignee: nobody → rob
Keywords: leave-open
Attached patch l10n_branding.patch (obsolete) — Splinter Review
Attachment #9159037 - Flags: review?(clokep)
Comment on attachment 9159037 [details] [diff] [review]
l10n_branding.patch

Review of attachment 9159037 [details] [diff] [review]:
-----------------------------------------------------------------

::: comm-merges/merge-central-2-beta.sh
@@ +56,5 @@
>    mv tmpfile beta/mail/config/mozconfigs/${plat}/l10n-mozconfig
>  done
>  
>  # Add --enable-official-branding to l10n mozconfig
> +sed -e '/--with-branding/' beta/mail/config/mozconfigs/l10n-common > tmpfile

I do not believe this is a valid sed command, I think you're missing a d at the end?

`sed -e '/--with-branding/d' beta/mail/config/mozconfigs/l10n-common`
Attachment #9159037 - Flags: review?(clokep) → review-
Attachment #9159037 - Attachment is obsolete: true
Attachment #9159521 - Flags: review?(clokep)
Attachment #9159521 - Flags: review?(clokep) → review+

https://hg.mozilla.org/users/bugzilla_standard8.plus.com/drivertools/rev/81b25a290bd7b40c6f275671c6297b0452e54fda

I think this can be closed, but not 100% sure. Rob -- please reopen if this isn't done!

Status: NEW → RESOLVED
Closed: 3 months ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 78.0
You need to log in before you can comment on or make changes to this bug.