Closed Bug 1644083 Opened 4 months ago Closed 4 months ago

Open extension popup windows in a lightweight window, not messenger.xhtml

Categories

(Thunderbird :: Add-Ons: Extensions API, enhancement)

enhancement

Tracking

(thunderbird78+ fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird78 + fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

Currently if an extension calls browser.windows.create({ url: … , type: "popup" }), a new instance of messenger.xhtml opens, the URL is loaded in a new tab, and everything else is hidden. While this works, it's a real mess and should be avoided.

Blocks: 1644000

This copies browserRequest.xhtml which has most of what we want, and modifies it to load WebExtension pages or any old URL, which is needed for bug 1644000. It's not complete (there's no context menu yet, for example) but is better than what we had, plus it allows the browser.identity API to be enabled.

Attachment #9154876 - Flags: review?(mkmelin+mozilla)

Hmm, I think I may change the names to extensionPopupWindow.js/xhtml. It could be easily confused with the other (in-window) type of popup.

Comment on attachment 9154876 [details] [diff] [review]
1644083-popup-window-1.diff

Review of attachment 9154876 [details] [diff] [review]:
-----------------------------------------------------------------

Seems fine to me. r=mkmelin
Attachment #9154876 - Flags: review?(mkmelin+mozilla) → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/1ae200f28e7b
Open extension popup windows in a lightweight window, not messenger.xhtml. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 79.0
Regressions: 1645263
Comment on attachment 9154876 [details] [diff] [review]
1644083-popup-window-1.diff

Kind of needed for WX APIs
Attachment #9154876 - Flags: approval-comm-beta+
Duplicate of this bug: 1644961
Duplicate of this bug: 1644964
Duplicate of this bug: 1630411
Regressions: 1649423
You need to log in before you can comment on or make changes to this bug.