Closed Bug 1644246 Opened 4 months ago Closed 3 months ago

Crash in [@ mozilla::ipc::FatalError | mozilla::ipc::IProtocol::HandleFatalError | mozilla::dom::PContentParent::SendActivate]

Categories

(Core :: DOM: Content Processes, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- fixed
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed

People

(Reporter: philipp, Assigned: nika)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-9523e730-177d-456d-8619-75d510200608.

Top 10 frames of crashing thread:

0 xul.dll mozilla::ipc::FatalError ipc/glue/ProtocolUtils.cpp:159
1 xul.dll mozilla::ipc::IProtocol::HandleFatalError const ipc/glue/ProtocolUtils.cpp:398
2 xul.dll static mozilla::ipc::IPDLParamTraits<mozilla::dom::PBrowserParent*>::Write ipc/ipdl/PBrowserParent.cpp:7160
3 xul.dll mozilla::dom::PContentParent::SendActivate ipc/ipdl/PContentParent.cpp:4196
4 xul.dll nsFocusManager::ActivateRemoteFrameIfNeeded dom/base/nsFocusManager.cpp:2181
5 xul.dll nsFocusManager::Focus dom/base/nsFocusManager.cpp:2342
6 xul.dll nsFocusManager::SetFocusInner dom/base/nsFocusManager.cpp:1540
7 xul.dll mozilla::dom::Element::Focus dom/base/Element.cpp:384
8 xul.dll mozilla::dom::XULElement_Binding::focus dom/bindings/XULElementBinding.cpp:9136
9 xul.dll mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy, mozilla::dom::binding_detail::ThrowExceptions> dom/bindings/BindingUtils.cpp:3203

this crash signature is showing up in increased volume since firefox 77.

Component: IPC → DOM: Content Processes

This method is fired because the PBrowser being sent in SendActivate is already destroyed when it is being sent. Normally we wouldn't crash if the actor a message is being sent over has been discarded, but we can't recover in the case where the actor is an argument, such as in these methods.

This should be fairly easy to fix by having the SendActivate and SendDeactivate methods be on PBrowser instead of PContent: https://searchfox.org/mozilla-central/rev/0e09b9191c02097034e46b193930f91c45b7885d/dom/ipc/PContent.ipdl#738-743

Assignee: nobody → nika
Severity: -- → S2
Priority: -- → P2
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e046748089d
Send Activate/Deactivate messages over PBrowser instead of PContent, r=kmag
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79

Please nominate this for ESR78 approval. It grafts cleanly as-landed.

Flags: needinfo?(nika)

Comment on attachment 9156106 [details]
Bug 1644246 - Send Activate/Deactivate messages over PBrowser instead of PContent,

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Occasional unnecessary main process crash.
  • User impact if declined: Browser will crash more frequently.
  • Fix Landed on Version: 79
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low-impact change to avoid unnecessary process crash.
  • String or UUID changes made by this patch: None
Flags: needinfo?(nika)
Attachment #9156106 - Flags: approval-mozilla-esr78?

Comment on attachment 9156106 [details]
Bug 1644246 - Send Activate/Deactivate messages over PBrowser instead of PContent,

Approved for 78.1esr.

Attachment #9156106 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
You need to log in before you can comment on or make changes to this bug.