Upon downloading mail from an IMAP server to a local folder, the mail file contains an extra line break at the end of each message.

RESOLVED WONTFIX

Status

MailNews Core
Database
--
trivial
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: Oneweb, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721

The mail file contains a single extra linebreak at the end of each
message/before the "From" - line. This is not the case in Messenger4.78, in
which there are no linebreaks added.

Reproducible: Always

Steps to Reproduce:
1. Copy at least 3 messages from an IMAP account to a local folder in Mozilla Mail
2. Do the same in Netscape Messenger
3. Compare the results.
Actual Results:  
There was a difference between the files created by Netcape and Mozilla Mail

Expected Results:  
Not added extra lines/linebreaks
(Assignee)

Comment 1

16 years ago
the extra linebreak doesn't affect anything, right? marking wontfix. There's no
reason that we should do exactly what 4.x does.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

16 years ago
just figured that since Mozilla was standards compliant, it might as well be 
completely so :)

"MESSAGE FORMAT
     A message encoded in mbox format begins with a  From_  line,
     continues  with a series of non-From_ lines, and ends with a
     blank line."

Also, i didn't mean to sound like a kid screamin (but 4.x does it!!!) :p, it was 
just a comparison to verify that it wasn't the mail server adding the extra 
line.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Assignee)

Comment 3

16 years ago
well, we do end with a blank line :-) this is a bit of a low priority at the moment.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
no need to change this since it makes no difference
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WONTFIX
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.