Closed Bug 1644498 Opened 2 years ago Closed 2 years ago

Consolidate devtools frame state bits into nsIFrame

Categories

(DevTools :: Inspector, task)

task

Tracking

(firefox79 fixed)

RESOLVED FIXED
Firefox 79
Tracking Status
firefox79 --- fixed

People

(Reporter: bradwerth, Assigned: bradwerth)

References

Details

Attachments

(1 file)

Devtools uses frame state bits to trigger the generation of "computed info" on some reflows. The computed info structures are used by devtools to inspect details of the layout process. Two of these bits are NS_STATE_FLEX_GENERATE_COMPUTED_VALUES and NS_STATE_GRID_GENERATE_COMPUTED_VALUES. These bits should be combined into a single bit value and moved to nsIFrame.h, which has more space for frame bits.

This patch takes the flags NS_STATE_GRID_GENERATE_COMPUTED_VALUES and
NS_STATE_FLEX_GENERATE_COMPUTED_VALUES and combines them into a single new
flag that is defined in nsIFrame.h, with accessors.

Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f73a200460d9
Transition devtools nsFrameStateBits to nsIFrame.h r=heycam

Also crashes on [@ InvalidArrayIndex_CRASH(unsigned long, unsigned long)] on multiple different files e.g. https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=305725392&repo=autoland&lineNumber=14995

Something is tripping the bitfield. I'm having trouble debugging it since it's tough to break on a bitfield memory change. I'll figure it out.

The test that reproduces the crash for me locally is layout/generic/crashtests/1278461-2.html.

(In reply to Brad Werth [:bradwerth] from comment #5)

Something is tripping the bitfield. I'm having trouble debugging it since it's tough to break on a bitfield memory change. I'll figure it out.

Nope, I just forgot to initialize the new bit in the constructor. Fix inbound.

Pushed by bwerth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a26ef3f0a2fd
Transition devtools nsFrameStateBits to nsIFrame.h r=heycam
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79
Flags: needinfo?(bwerth)
You need to log in before you can comment on or make changes to this bug.