Closed Bug 1644568 Opened 2 months ago Closed 2 months ago

Remove instance of WhyPaused that is not useful to the user from debugger/src/components/App.js.

Categories

(DevTools :: Debugger, task)

task

Tracking

(firefox79 fixed)

RESOLVED FIXED
Firefox 79
Tracking Status
firefox79 --- fixed

People

(Reporter: kyleknaggs, Assigned: kyleknaggs)

Details

Attachments

(1 file)

The purpose of the WhyPaused component is to convey information about why the code in the Debugger has been paused. Instances of the WhyPaused component are currently rendered by 2 different components.

  1. devtools/client/debugger/src/components/SecondaryPanes/index.js
  2. devtools/client/debugger/src/components/App.js.

The instance of the WhyPaused component rendered by devtools/client/debugger/src/components/SecondaryPanes/index.js is useful to the user. Once the code in the Debugger has been paused, the mark up that it renders contains useful information about why the Debugger has been paused and can be found at the very top of the secondary panes sidebar.

The instance of the WhyPaused component rendered by devtools/client/debugger/src/components/App.js is not useful to the user. It is only rendered if the secondary panes sidebar has been closed. The mark up that it returns is as follows:

  1. If the secondary panes sidebar is hidden by the user after previously being visible, WhyPaused returns:
    <div class=""></div>

  2. If the secondary panes sidebar is hidden by the user and the componentDidUpdate() method in the WhyPaused component has been run WhyPaused returns:
    <div class="pane why-paused"></div>

Because the mark up returned by WhyPaused when rendered by devtools/client/debugger/src/components/App.js is is not useful to the user in either of these cases, WhyPaused should be removed from devtools/client/debugger/src/components/App.js.

Summary: Remove instance of WhyPaused from debugger/src/components/App.js that is not useful to the user. → Remove instance of WhyPaused that is not useful to the user from debugger/src/components/App.js.

Removes the instance of WhyPaused in debugger/src/components/App.js as the mark up that it returns does not contain useful information and is never visible to the user.

Assignee: nobody → kyleknaggs
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a5cb1a40413e
Remove WhyPaused from debugger/src/components/App.js r=jlast
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79
You need to log in before you can comment on or make changes to this bug.