Closed Bug 16446 Opened 20 years ago Closed 20 years ago

Java method returns wrong value for int type to JavaScript.

Categories

(Core Graveyard :: Java: OJI, defect, P3, major)

PowerPC
Mac System 8.6

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: leilag, Assigned: drapeau)

References

()

Details

Using 10/13/99 Mozilla build on MAC and MRJPlugin092499. This happens on
MAC only.

To reproduce,
- Load
http://lonely/blackwood_qa/src/OJI/PluginTest/sunw/LiveConnect-method-returnType-int.html

  This test accesses a public method that returns an integer value. In this
case, it is set to return 2147483647.
  However, JavaScript receives 32001 instead of 2147483647.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
THIS IS NOT A BUG!!!
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.