If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Now slower when multiple frames

RESOLVED WORKSFORME

Status

Camino Graveyard
General
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Stephane Moureau, Assigned: Brian Ryner (not reading))

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
Download this 18Kb archives and open the "Donate.htm" page locally.
Since several(~8) days, the latest builds are now very slow when you want to
scroll to the right any of the 3 big left frames to see the middle of each frame.
In previous version, you can click on the scroll bar of each of those frames and
they were scrolled one after another almost immediately.
Now it's extremelly slow, almost 2 or 3 seconds to see the result of an action.
Even clicking on the button 'click here' in the center of those frames is
waiting and most of the time is not executed. You must do everything very slowly
to be sure it will work.

I was trying to find a duplicate and I've found this (gif min time)
http://bugzilla.mozilla.org/show_bug.cgi?id=164099
which seems to be quite new and might be related as those frames have a lot of
animated gif.

I don't think it's a network problem as the first time I saw that slow down, it
was after reinstalling a new build and it was ok just before.

I don't know which build show first that slow down, sorry.
Build 0820
(Reporter)

Updated

15 years ago

Comment 1

15 years ago
->Pinkerton
Assignee: saari → pinkerton
-> bryner
Assignee: pinkerton → bryner

Comment 3

15 years ago
That page has 22 frames, what do you expect?
(Reporter)

Comment 4

15 years ago
The first html was released on 08-02 and the last one around 08-05. Just after
that date, the total of 7 clicks (3*(scroll right + button click)+button click)
required on the 4 bigger frames were made very quickly, even if the pages were
not entierely downloaded, no delay, no spinning cursor.
The click-here button and several other images were in cache, so you were able
to reach them immediately.
With the latest buildS everything is extremely slow, something has changed in
Chimera... cache, frames, wait for page to be completed,...
Before you were also able to make the 3 scroll and then the 3 clicks even when
the pages were 'not yet' downloaded.
My latest test has been made with 0824 and it's slow.

Comment 5

15 years ago
Dup of bug 151344?
(Reporter)

Comment 6

15 years ago
Great news, the Donate page is now as fast has it used to be before.
Test made with build 20021026 - OS X 10.1.5.
I think the slow down was appearing when there was a lot of animated gif images,
like in the 4 biggest frames.
I think it can changed to FIXED.

Comment 7

15 years ago
Resolving WFM per comment 6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 8

15 years ago
My guess is that the explicit 'Composite' in the plugin scrolling code caused
this. I removed it.
You need to log in before you can comment on or make changes to this bug.