Need prefs for Ctrl+Enter behavior in URL Bar

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
16 years ago
10 years ago

People

(Reporter: oliver, Assigned: hewitt)

Tracking

Trunk
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Since the issue of Ctrl+Enter is sill open(bug #37867, bug#164323) 
and there are two strong position, maybe a preference option is needed.

The prefs should looks like this, using radio buttons:
Ctrl+Enter behavior in URL bar:
( ) open the URL a new window
( ) autocomple the URL in the current window

Already both behavior are working:
- open a new window: current build 1.0.x and 1.1.x
- autocomplete URL: the patch is on bug #37867 (tested by the poster)

Hopelly, this bug will close bug #37867 and bug #164323 and 
make everybody happy. (This is just a sugestion)
(Reporter)

Updated

16 years ago
Depends on: 164323
(Reporter)

Comment 1

16 years ago
Using checkboxes should work better, as sugested in bug #164323 comment #20.
Patch dns-completion-ctrl-enter-4.patch of bug #37867 already implement
a solution for this bug using checkboxes.
Now, we need an GUI change in the preference window.
(Reporter)

Updated

16 years ago
Depends on: 37867

Comment 2

16 years ago
No, we have way too many prefs already. We should rather change the keyboard
shortcut to something else than Ctrl+Enter than make it a pref. WONTFIX.

(mpt, i'd like to nominate this one as Stupid Pref Request Of The Day :-) )
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

16 years ago
I filled this bug to help IE users.
Just post it to "Stupid Bug Of The Day" website:
http://www.sbotd.com/
I you want this kind of bugs to stop, just make bug 37867 WONTFIX.
Thanks

Comment 4

16 years ago
> I filled this bug to help IE users.

Yeah right. Like an average IE user would ever open the Preferences panel.

And you didn't fill it, you filed it.

> Just post it to "Stupid Bug Of The Day" website:
> http://www.sbotd.com/

I don't know what you're talking about.

> I you want this kind of bugs to stop, just make bug 37867 WONTFIX.

You filed three bugs in three days about the same feature! That is *not* a good
way to get it implemented!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

16 years ago
>> I filled this bug to help IE users.
>
>Yeah right. Like an average IE user would ever open the Preferences panel.
This will make Mozilla more IE Friendly and should be enabled by default, 
then, the  Mozilla power user will find that option easylly.

>
>And you didn't fill it, you filed it.
Thanks, my english is bad.

>
>> Just post it to "Stupid Bug Of The Day" website:
>> http://www.sbotd.com/
>
>I don't know what you're talking about.
This is for your topic about "stupid bugs"

>> I you want this kind of bugs to stop, just make bug 37867 WONTFIX.
>You filed three bugs in three days about the same feature! That is *not* a good
>way to get it implemented!

I filled 3 specific differents bug:
164309    Force domain autocompletion with Ctrl+Enter like in IE
164323    Do not use Ctrl+Enter in URL bar for new window
164494    Need prefs for Ctrl+Enter behavior in URL Bar

In bug 164309 I'm not asking about the .net, .org, etc autocompletion neither 
to the feature to configure these domains. Bug 164309 is only the same
as the summary of bug 37867. If you read bug 37867 you will note that a
2 year conversation can get really off topic. They sugested way many more
features as in the summary.

In bug 164323 I sugested not using Ctrl+Enter at all. Don't bind Ctrl+Enter
to anything. This was created beacuse in bug 37867 people says that Ctrl+Enter
can not be used for URL autocompletion because is already taken. So, let
free that binding and it would not be taken anymore.

In bug 164494 I sugested a GUI for my patch to bug 37867 to make
it easier to configure it. Note that the patch works right now.


If I should talk many diferent topics in one bug and just generallise it, 
just let me know. I'm not a bugzilla master, just want to have specific
short talks about topics.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.