Closed Bug 1644963 Opened 2 years ago Closed 2 years ago

View Saved Logins autocomplete button no longer applies the filter on Lockwise

Categories

(Toolkit :: Password Manager, defect)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- wontfix

People

(Reporter: jaws, Unassigned)

References

(Regression)

Details

(Keywords: regression)

STR:
Visit a website, login, and save the login for the site
Log out of the website, and view the login form again
Delete the autofilled password
Click on the blank password field
Click on the "View Saved Logins" button in the autocomplete dropdown

Expected:
Lockwise (about:logins) is opened and the search filter is populated with the origin of the previous page

Actual:
Lockwise (about:logins) is opened but the search filter is not populated and all logins are displayed

Confirmed via mozregression that this was regressed by bug 1618311.

Flags: needinfo?(edilee)

[Tracking Requested - why for this release]: regressed in Firefox 77, would be good to get this fixed in Firefox 78

Duplicate of this bug: 1644962

This was an intentional change from Katie: bug 1598464

I do miss the filtering sometimes but also understand the confusion of being taken to a page showing there are no saved logins when in fact there are many but they aren't visible due to the filter.

Flags: needinfo?(edilee)
Priority: P1 → --
Regressed by: 1598464
No longer regressed by: 1618311

Thanks, I missed that context. I'll close the bug as invalid. The gains from the change outweigh the losses.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Duplicate of this bug: 1650207
See Also: → 1741092
You need to log in before you can comment on or make changes to this bug.