(html source mode) "save" command makes editor going to "normal" mode

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
16 years ago
9 years ago

People

(Reporter: bugzilla3, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I am using 2002082504. Steps to reproduce:
1. Open a page in composer. Switch to html source mode.
2. Type something.
3. Save

Expected results:
The document is saved and the editing mode is still html source.

Actual results:
After saving, editor goes to preview mode.

Comment 1

16 years ago
-->cmanske
did this get changed with recent changes or is it still broken?
Assignee: syd → cmanske
(Reporter)

Comment 2

16 years ago
Now a save (or save as) makes the composer to switch to "Normal" tab (instead of
Preview), so it's still broken. Seeing this on 2002091904/Win2K.
Summary: (html source mode) "save" command makes editor going to "preview" mode → (html source mode) "save" command makes editor going to "normal" mode

Comment 3

16 years ago
This is a feature request. HTML Source is really "second level" editing.
Composer is really an HTML (DOM) editor. Thus when saving from source mode,
we change back to "normal" to rebuild the HTML document. We could save the text
in HTML source to the file, of course, but there is very valuable reparsing and
validaton according to the current DTD that is done when document is rebuilt.
So this is a good thing to do!
So the feature is to switch back to the HTML Source mode automatically after
saving if this is the current mode. The trouble is, we currently don't 
coordinate the insertion point (the selection) when going back and forth
(that is bug 47040), so the HTML Source window would reappear scrolled to the top.
Basically, this is easy to do and probably is a good idea.


Keywords: nsbeta1
Target Milestone: --- → mozilla1.2beta
(Reporter)

Comment 4

16 years ago
Charles, I won't disagree with you about the reduced importance of html source
mode, since Mozilla editor is not intended as an all-purpose html editor.
However, switching to another mode for checking purposes and returning not only
makes an uneseccarry scrolling but also induces a ui inconsistency (re-parsing
can't be instant). Are we sure we still want it? As far as I can see, Frontpage
doesn't do this. Editing html source (or even breaking the page) is on the
responsibility of the author, imo.

Comment 5

16 years ago
Note that if you don't edit anything in source window, but use it just to "check",
we don't reparse. Once you make any editing change, we set a flag to reparse.
Status: NEW → ASSIGNED

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1-
Product: Browser → Seamonkey
Assignee: cmanske → nobody
Status: ASSIGNED → NEW
QA Contact: sujay → composer
Target Milestone: mozilla1.2beta → ---

Comment 6

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 7

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.