Closed Bug 1645162 Opened 11 months ago Closed 11 months ago

Partial generation fails MAR signature check on Oak (dep instead of nightly)

Categories

(Release Engineering :: Release Automation: Other, defect)

defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
Tracking Status
firefox79 --- fixed

People

(Reporter: agashlin, Assigned: agashlin)

References

(Regression)

Details

Attachments

(1 file)

The attempts to build partials for oak failed in this job when checking the signature of the old complete MARs. I think it should be using the nightly key instead of the dep key. It looks like this was also an issue for comm-central, fixed in bug 1632531.

I'll try fixing this on oak, should be pretty simple, and if it works out I'll submit a patch.

This looks ok with a push to oak (treeherder), and I checked that an old build from March (this one, win64) was able to use the new partials.

Attachment #9156138 - Attachment description: Bug 1645162 - Use nightly cert for oak MARs. r?sfraser → Bug 1645162 - Use nightly key for oak MARs. r?sfraser
Pushed by sfraser@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4bf2ca9948c2
Use nightly key for oak MARs. r=sfraser
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.